Sonos callback URL parameter is not used for upnp callback registration


as I’ve put my openhab instance behind nginx, I would need to change the callback IP to the one that belongs to nginx. As far as I’ve understood, the parameter Callback URL in the Binding configuration could be used for that.
I’ve set it to http://<ipofnginx>:8080, but when checking the registration on packet level, it’s still registering with the ip of the openhab machine.

Callback: <http://<ipofopenhab>:8080/upnpcallback/dev/RINCON_xxxxxxxxxx_MS/svc/upnp-org/ContentDirectory/event/cb>\r\n

Any idea what’s going wrong? Or did I misinterpret the meaning of the parameter?

I’ve been playing around a little bit and tried to pin down the issue in the code … without any luck up to now unfortunately, but something else came to my mind. As it seems that the configuration should be working based on the comments here, is it possible, that it’s discarding the configuration entry if it’s not a local interface on the OH machine?

@kgoderis I recognized, that the Handler has been written by you, so maybe you can shed some light on this topic?

In my setup i’m running OH in docker within a user defined bridge network. The requests from my pysical LAN are forwarded by an nginx instance, that is exposing the relevant ports and forwards them into the docker bridge-network. So from the docker container point of view, the IP that it needs to provide for subscription is not availabe in the container, as it’s the one, that belongs to the nginx instance on the pyhsical network.