Sonos notification not working anymore

Hi there,

I had set up my door bell to play a notification on Sonos. Worked until upgrade to 4.x
In the Thing, the default volume is set. I play a sound on my webserver (mp3). Tested it on a Move and Play1. Both worked before. When playing the sound via normal play command, it is ok. Of course, it is then locally and not on the internet. Playing it via browser also works, so assuming that the access should still be the same.

The major question is: what has changed since last week.
I have 3 openhab instances, all same behaviour.

currently I send following command in a rule:

sendCommand(Sonos_Notification_Move, "")

what works:

sendCommand(Sonos_Favorite_Move, "doorbellDingDong")

However this will stop any playlist, so only a workaround.

Any ideas?


Notice the / before the http…

There is a local workaround using a feature of sonos but you need java and also the latest more here

There was nothing changed in the binding.
One advice: reboot your Sonos devices, especially if you recently updated their firmware. It could help.

Thanks, just a copy/paste issue, rule is without the /.

But thanks anyhow

Thanks Lolodomo, unfortunately didn’t help. Is there a debug feature?
Looking at the events log it gives me the two entries,

2023-11-05 15:20:52.481 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'Sonos_Notification_Move' received command
2023-11-05 15:20:52.482 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'Sonos_Notification_Move' predicted to become

I am surprised it could work with a simple HTTP URL. Are you sure it worked one day with such value?

either that or I had some strange noises in my head :wink:

So what would be the right notation then?

is there any more documentation on the setup? I basically tried any combination I could think of and nothing works.
setting the url in the binding configuration, only host, with port, without, with static, full incl. .mp3 and same in rules.
What would be the correct command to trigger a notification?
sendCommand(Sonos_device_name_Notification, “sound.mp3”) or does this need to be the full path again?
Sorry, I just give up. I tried to find a solution in various posts and not able to find.

You sure you read the docs. Anyway without knowing anything about your setup you should have

Thing sonos:Move:living [ udn="RINCON_000E58D8403A0XXXX", refresh=60]
String Sonos_PlayUri      "Playing URI [%s]" <text>             (Sonos) {channel="sonos:Move:living:playuri"}
rule "Sonos Play Web Radio URI"
when Item Sonos_PlayUri changed 
    //Set URI to play
    //Set the Volume

Or you can use the notificationsound channel.

Then using the Sonos as audio sink you can do something like

playStream("sonos:Move:living", ""

All this comes from the docs.

If the above doesn’t help post your config rules etc as much information as possible to be able to get more help.

Thank you for your help. Yes I did read the documentation and the part about the notification is rather “slim”

That all works, I just struggle with the notification sound:


String Sonos_PlayUri_Move      "Move Playing URI [%s]" <text>             (Sonos) {channel="sonos:zoneplayer:RINCON_5CAAFDD2CA52xxxxx:playuri"}
String Sonos_Notification_Move     "Move Notification"          <text>            {channel="sonos:zoneplayer:RINCON_5CAAFDD2CA52xxxxx:notificationsound"}

this works on the default (specified in the audio setup)


this also works with a favorite

sendCommand(Sonos_Favorite_Move, "doorbellDingDong")
sendCommand(Sonos_PlayUri_Move, "x-rincon-mp3radio://")

However this does not change the situation, that the notification does not work. It just does not play.

sendCommand(Sonos_Notification_Move, "x-rincon-mp3radio://")

Please enable DEBUG logs for the Sonos binding and tell me if you see particular entries.
Do you see this message: Notification feature not yet implemented while the current media is being played

It can happen that notification playback is not pissible depending on what source you are currently playing or how it was started. Please provide this information.

Try your notification while your current source is tuneIN.

Thanks @Lolodomo

nothing playing on Sonos device:

sendCommand(Sonos_Notification_Move, "x-rincon-mp3radio://")
2023-11-07 19:36:46.853 [DEBUG] [s.internal.handler.ZonePlayerHandler] - playNotificationSoundURI: currentURI null metadata null
2023-11-07 19:36:46.864 [DEBUG] [s.internal.handler.ZonePlayerHandler] - Notification feature not yet implemented while the current media is being played

TuneIn station playing:

sendCommand(Sonos_Notification_Move, "x-rincon-mp3radio://")
2023-11-07 19:40:37.428 [DEBUG] [s.internal.handler.ZonePlayerHandler] - playNotificationSoundURI: currentURI null metadata null
2023-11-07 19:40:37.437 [DEBUG] [s.internal.handler.ZonePlayerHandler] - Notification feature not yet implemented while the current media is being played

So basically twice the same results. However that part does not seem to be right:

currentURI null metadata null

I started various stations via PC controller. Also via iphone. Apple music. paused. All same outcome.

Yes that is not normal.
Are you running openHAB inside docker?
If true, you could have a docker setup problem (related to network) leading to UPnP not working as expected

it is running on a VM (Oracle virutalbox).
However same outcome on an openhabian on RPi.

Stop the Sonos bundle ans start it again. Look at logs and tell me if UPnP services registration is succeeding or not.
My hypothesis is that it fails… Check also that jupnp bundle is started.
I imagine you have a network problem between your VM and your Sonos devices leading to UPnP not working.

Did you check that your things are ONLINE?

ok, all things are online. I do not see any errors when removing and re-installing the sonos binding. All seems to be ok. However will investigate on the UPnP topic a bit. Thanks for your help so far.

the one on the RPi works with notifications. So suspicion that it has to do with the VM might be true. keep you posted if I find out something.

Thank you, @Lolodomo

Hello, I have the same problem. Since the Openhab update it no longer works. If I restore the backup from before the update, it works again. So it has something to do with the latest update. Has anyone already found a solution?

Hi, I have the same problem. No SONOS information shared in Openhab items such as Album Art, artist information etc, only activities. Did you solve it for all of your Sonos Things and what do you mean with "the one on the RPi works with notifications? Btw, the Spotify thing does show this information. Thanks for feedback, BR Henk

Hi all

I had a similar problem with my sonos not resuming after notification.

I found a relatively simple answer at Supporting audioClip API · Issue #530 · bencevans/node-sonos · GitHub
which uses curl, so can be scripted etc.

I trigger a script on my RaspberryPi from node-red

job done!