Sonos speakers not found / openhab bind’s to wrong interface?

Hey guys,

I got an sonos issue here. Probably you guys are tired of this question already but I could need a hand here.

So that’s the story:
First the Sonos binding worked just fine. I used openhab 3.1 and the speaker was recognized immediately and worked like a charm. Then after the whole log4j security issue I updated my docker container from 3.1 to 3.2. Well I messed that update up and had to start over with a clean openhab 3.2 installation. That was on me and is not the point here.

Anyways since OH3.2 the sonos speakers can’t be found anymore. I checked the documentation which says the boxes set the TTL to 1 and you have to make sure openhab is on the same network. So I checked the container and the network id of the container is assigned to network “host”.
With that I would say they are on the same network.

Then I did a tcpdump on the raspberry and hit the scan button on OH3 UI.
During the scan I can see packets from the sonos speaker addressed to my raspberry.
So the request from OH is sent and the answers at least received from the host.

Next thing was a check on the openhab.log there is something which made me curious:

2022-01-21 21:00:38.831 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Time zone set to 'Europe/Berlin'.
2022-01-21 21:01:03.352 [WARN ] [        ] - Found multiple local interfaces - ignoring
2022-01-21 21:01:03.357 [WARN ] [        ] - Found multiple local interfaces - ignoring
2022-01-21 21:01:03.362 [WARN ] [        ] - Found multiple local interfaces - ignoring
2022-01-21 21:01:03.366 [WARN ] [        ] - Found multiple local interfaces - ignoring
2022-01-21 21:01:03.371 [WARN ] [        ] - Found multiple local interfaces - ignoring
**2022-01-21 21:01:03.376 [WARN ] [        ] - Found multiple local interfaces - ignoring**

OH finds multiple interfaces on the host. What’s pretty obvious for me, because there a there but the last line is my eth0 interface and got ignored. I believe now this is the reason for the sonos issue. Can I adjust to which interface openhab is binded? Any other ideas?

Thanks for your help!
Greetings rick

Logged in as admin user go to settings => network. You can set the primary network address.

Hey Wolfgang,

Ok setting the IP was easy. How could I missed that? xD

Unfortunately that did not help. Guess I have to turn on some debug logs and look deeper into into.

Did you do a restart of openhab service ? I assume that setting only applies after a restart of it.

Yes sir… restarted the openhab container and just and case the sonos speaker