Sonos things offline after some time


I am using Openhab insid a docker container (with host networking) on a arm device to control my KNX system. This is working fine, but the four Sonos things go offline after some time, maybe an hour or so. Doing a restart bundle:restart org.jupnp in karaf console let the come back online. When online, I am able to control them and their status with OH.

I put my Sonos devices into a seperate network / vlan for security reasons. As Sonos is using multicast for communication, I configured a igmp proxy on my unify equipment ( This is working, sonos apps on Windows, Android and iOS does not see any difference. Also a test install with home assistant is able to control sonos, even after a runtime of 3 days. Only in OH they get offline after some time.

As it seems that I am the only user with this problem I suppose its caused by this non standard setup.
Does somebody have an advice how to throubleshoot this? I dont have any java skills.

Edit: tested with several 2.4 milestones and 2.5

Hey Fabi,

It’s not just you; it’s been happening to me for over 9+ months now. I’ve tried everything and nothing seems to completely cure it. I do have a normal setup (OH on a Synology (no docker), everything on the same subnet, using SonosNet and some hardwired, etc.)

I have also tried numerous version of the Sonos binding - same results.

I’m running the latest Sonos patch level across 14 Sonos devices. All of mine comprise of Amps and Sonos 1’s which some are in pairs.

Best, Jay

Hello Jay,

good to know that I am not the only one with this issue. Thank you for the posted thread. I have checked the network matrix - two green and one yellow device. That should be…

Bounty Created:

Best, Jay

Hi, i think no news and solution about this problem… or? I am using now OH 4.1M3 and still the same problem. I am running ir on a Qnap Docker, Netword Host-Mode… its running perfect… bu still this sonos problem! I have SMA fotovoltaic devices which are using upnp and multicast and are running without a problem… but Sonos still has this problems… still no ideas ?

There were many threads explaining how to setup network for docker. You should search more recent threads than reopening a 4 years old one.
Sorry to not give you the solution directly, I just have no experience yet with docker.