Sony Devices Binding

openhab2
Tags: #<Tag:0x00007fd31498c8c8>

(Tim Roberts) #441

@beardedfool
Read through your issue over on the sonyapilib - pretty much confirms my suspicions above that the TV didn’t handle the power commands but glad to see you got some ‘external’ confirmation. I’d definitely hit it with IR in that case (either your own custom board, a itach/global cache or with NEEO [couldn’t help myself]). All three would do the job…


(Tim Roberts) #442

@surftu

Hard to answer that (although I’d stick with Sony or Samsung) - I have all sony tvs. If you do go with sony, don’t go with the lower [cheaper] versions if you want automation - the lower versions don’t implement home automation features at all. I know the 800 and 900 series work (I have the a few 900 series and 850 series).

Yes sony has removed features in the past - specifically on TVs, the IRCC feature has been slowly taken away (use to be on the 850c - no longer). However, that’s because the scalar service really does both the IRCC and DIAL combined. They will likely be sticking with scalar for awhile since they are opening up their API now (maybe @freke would like to comment on this issue).


(Tim Roberts) #443

@Wexy101

There is an, outdated, readme available on my github (https://github.com/tmrobert8/openhab2-addons/tree/1231-Sony/addons/binding/org.openhab.binding.sony) that you can view for more information on the binding. I’m in the process of making this binding mergable and will be updating the readme last (just wrapped up on the simpleip, dial and ircc - about to start in on the scalar stuff). Once it’s merged - there will be an official readme available then.

The commands file usually just points to some file in your transformation directory (like ‘C:\openhab2.2\conf\transform\myir.map’). However, you shouldn’t really try to setup a thing manually - let the paperui discover your device for you (and it will do all the configuration you need). Manual configuration is really tough for this binding


(Wexy101) #444

Thanks Tim.
In keeping with the nube theme. I totally agree with non manual setup but I can’t see any other option than the above. I’ve pressed the scan button top right but don’t have the Sony option to select and when I add select add I can’t get beyond the option I requested. Is there something in-between in missing for automatical finding the TV??

Fyi: best of luck with you completion of the development of the binding and it’s integration with the openhab system as a regular!


(Tim Roberts) #445

You’re probably running into the same issue as others (the addon doesn’t work with OH2.2 because I’m using an older http component that was phased out). You’ll probably need to wait until my next version for this to work


(ThomasK) #446

It might be that you are too impatient: when in the Paper UI Things Config, when I select the Sony Binding it takes 20 seconds to show ‘online’, and another few to show the things (RPi 3). In the beginning I was too impatient :slight_smile:


(Wexy101) #447

I sorted this back then by manually creating the map file in the field “Commands map field”, ie simpleip-4d3328ad.map. And it just worked. is that a permissions issue, not being able to ceate the file name.


(Jonas) #448

Hello!
I updated to OH 2.2 and used the latest snapshot provided here.
My TV works but i recognized, that the Volume Command disappeared.
I can remember that i had this issue before but after i re-added my KDL 55w805c it worked again.
Now it does not.


(Mihir Patil) #449

The binding worked on my rpi3 on Openhab 2.2. (I can turn my Blu-Ray player off and on). I type eject into the IRCC command box, but nothing happens, though. How would I do this?


(Jonas) #450

Read here:


Eject would be:
AAAAAgAAAJcAAABIAw==


(Jonas) #451

I desperately try to find the command to switch to TV Program. All i find are specific commands for a channel. is there nothing like the “TV-Button” on the Remote in Scalar?

Thank you!

EDIT:
It would be great to be able to read the current TV-Channel as well. Is this possible? if yes, how?


(KD) #452

Dumb question, but I do not find the binding in paperui… Is it normal ? I’m still new on OH2


(SiHui) #453

It’s a market place binding, so you need to first install the market place addon (Eclipse IOT Market, MISC tab) , then you are able to see and install the Sony devices binding:

1

or use the link in this post to install it manually:

Also make sure you know about:


(KD) #454

Ok, so I was able to install and get the on/OFF working and a display of channel and input. I’ll see what else can be done, like switch automatically to another channel at a specified time or something like that


(KD) #455

So I’m able to use the Simple IP

But for the 3 other bindings, they remain offline. I used the URI provided in an older post, maybe that’s the issue

Here is my .things :
sony:simpleip:home [ ipAddress=“192.168.0.26”, commandsMapFile=“braviaircodes.map”, netInterface=“eth0”, ping=30, retryPolling=10 ]
sony:dial:home [ irccUri=“http://192.168.0.26:50201/dial.xml”, macAddress=“70:26:05:0c:ef:18”, refresh=-1 ]
sony:ircc:home1 [ irccUri=“http://192.168.0.26:50001/Ircc.xml”, macAddress=“70:26:05:0c:ef:18”, commandsMapFile=“ircccodes.map”, accessCode=“0000”, refresh=-1 ]
sony:ircc:home [ irccUri=“http://192.168.0.26:20970/sony/webapi/ssdp/dd.xml”, macAddress=“70:26:05:0c:ef:18”, commandsMapFile=“ircccodes.map”, accessCode=“0000”, refresh=-1 ]
sony:ircc:home2 [ irccUri=“http://192.168.0.26:52323/dmr.xml”, macAddress=“70:26:05:0c:ef:18”, commandsMapFile=“ircccodes.map”, accessCode=“0000”, refresh=-1 ]
sony:ircc:home3 [ irccUri=“http://192.168.0.26:8080/description.xml”, macAddress=“70:26:05:0c:ef:18”, commandsMapFile=“ircccodes.map”, accessCode=“0000”, refresh=-1 ]
sony:ircc:home4 [ irccUri=“http://192.168.0.26:50001/cers/getSystemInformation”, macAddress=“70:26:05:0c:ef:18”, commandsMapFile=“ircccodes.map”, accessCode=“0000”, refresh=-1 ]

I tried with different URI, for webScalar, I wasn’t able to find any URI example


(David Åberg) #456

Just a short notification @tmrobert8 I have now updated the pull request at eclipse/smarthome with two new soundbars that is now supported by the Audio Control API.


(KD) #457

Hi Thomas

Could you share your “thing” definition for the scalar ? Can’t get scalar to work with my TV, only simpleIP


(scott dee) #458

i’d been using this on 2.1 without much issue and for a time it was working on 2.2.0 but recently I believe this binding has been crashing my OH with java heap errors.
I see now that it’s not really compatible with 2.2.0 (and i’ve moved to 2.3 now) so my reply is mostly to tag me on this thread so I can see updates but also to document that for whatever reason this really isn’t playing nice on my system.

thanks for your work, looking forward to an updated binding. Thanks!


(ThomasK) #459

Well, the thing definition is automatically done by the plugin. it is found in the JSON db at

\\openhabianpi\openHAB-userdata\jsondb\org.eclipse.smarthome.core.thing.Thing

but was entered via Discovery. If it wasn’t discovered, sth is wrong, I would say.

This file contains a lot of entries like:

        {
          "acceptedItemType": "String",
          "kind": "STATE",
          "uid": {
            "segments": [
              "sony",
              "scalar",
              "a2686999-8d9f-48f1-b37c-bc558eebf92a",
              "appControl-com__0sony__0dtv__0org__0xbmc__0kodi__0org__0xbmc__0kodi__0Splash-apptitle"
            ]
          },

(Jonas) #460

Does anyone have an answer?