Sony Projector communication error

I’ve installed the SonyProjector binding to control the projector via ethernet. When I’ve configured the settings for the different bindings, I’m able to change the calibrated preset, the video input and read the power state through PaperUI Control.

But when I switch the projector to OFF (through the PaperUI Control), the projector goes to the state Cooling1. But after a couple of minutes I’ve lost my connection so I can no longer switch the projector back ON. The log shows: ‘sonyprojector:ethernetconnection:5bc52354’ changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Opening SDCP connection failed: No route to host (Host unreachable).

When I turn the projector ON by remote control (so not by using OpenHAB), the log shows: ‘sonyprojector:ethernetconnection:5bc52354’ changed from OFFLINE (COMMUNICATION_ERROR): Opening SDCP connection failed: No route to host (Host unreachable) to ONLINE

What am I doing wrong?


That seems a reasonable outcome.

Have you tried a WoL method to turn it back on?

Where should I define the wake-on-lan?

Well, to test it out you might just create an extra Item, install the binding, and have a play.

@rubbens16: you certainly have a projector setting to avoid your LAN interface to be shutdown when the projector is in standby.
What is your projector model ?

I have the Sony VPL-HW65ES. I’ve defined in an items file:

Switch Home_SonyProjector_Power	{wol=""}

This seems to be working.

You can link an Item to multiple bindings/channels; so you could link the same Item for the OFF/status function via Sony binding.

I’ve added that wol binding to a switch. It worked a couple of days, but no longer.

I cannot figure out what have been changed in the meantime except I received an update of OpenHab on my Ubuntu. I’ve also added extra things to my configuration, but the logs doesn’t provide an error when loading the things file.

I’ve deleted the thing and the binding and reinstalled everything. Let’s see if this would solve my problem.

I have issues with this binding.

I can power on/off the projector by a Switch item. But after a couple of weeks, it stops working. The only way to get this working again is to remove and reinstall the binding. Afterwards the Power switch will work again. Does this indicate a bug in this binding?