Squeezebox cannot stream Notification from Openhab2

Tags: #<Tag:0x00007f5ca56b0c70>
  • Platform information:
    • Hardware: AMD64/1G/10G (it’s on a vm)
    • OS: Ubuntu Server 18
    • Java Runtime Environment: openjdk-jre8
    • openHAB version: 4.2.7
    • Squeezebox server is running on same virtual machine host as openhab2

So I’m working on a smarthome system, I’ve done openhab2 and HA before in a very small capacity but this is a first for me.
I’m having the wierdest time with squeezebox server and squeezeboxes - they’ll play any stream, any audio file, accept commands, anything - except tts. I’ve done a little debugging by myself but no luck:

  • I’ve plugged the squeezebox into ethernet and tried wifi.
  • It cannot stream audio files from the server.
  • It will accept streaming URL’s from the server, unless I tell it to stream a file from the server - such as 000.000.000.000:8080/static/test.wav
  • Any other audio sink - such as the web interface - will stream tts just fine

I really am stumped, please help!

I tried using squeeze boxes for TTS. I have house full of them. I gave up in the end as it was too problematic and was likely to perform badly.

Instead I bought Amazon echo’s do to the TTS and it works beautifully with openHAB with the bonus that communication can go in the other direction… ie voice commands of home automation devices.

Hi,

Are you using pico- or marytts? If yes, same issue here.
I’m not the developer of these bindings, so maybe I’m speaking before my turn, however as far as I understand it, the pico- and marytts bindings spit out a wav file in a format (mono, low sample rate) that Squeezebox just isn’t able to handle. Maybe I’m mistaken, and in that case someone should correct me :slight_smile:
The only way I managed to get picotts audio output to play correctly on the Squeezebox system, was by upmixing the mono output file to a stereo wave file with a sample rate of 44.1 kHz, and convert that to mp3 and feed the mp3 file to the Squeezebox system. I’m on Linux so I used sox and lame to do that (picotts | sox | lame). It does not fix the binding problem though.
I took a look at the picotts binding code, and based on that I guess that the conversion from mono, low samplerate wave to mp3 could be added in just a couple of lines, however my Java coding skills are a bit poor, so I never tried it. Maybe one f the guru’s around here wants to give it a try?

Best regards,
Jesse

This may be the cause of the issue you’re having.

It also appears that Michael may have fixed the issue in the LMS. What version of LMS are you running?

My squeezebox version is 7.9.3 - and it was a nightly build too. I think this may have something to do with callback URL’s or file hosting - I can’t even access a static wav file from my server from the squeezeboxes. Strangely enough the doorbell and woof works though.

If openHAB and the LMS are in the same VM, why do you think it might have something to do with the callback URL? Did you set the callback URL in the binding config?

They aren’t on the same VM, they are on the same VM host. I have openhab and backend services separated.

Sorry, I misunderstood. Have you tried setting the callback URL in the binding config?

Yes I have - I’ve tried openhab’s IP and its ip:8080.