SSE subscription failed: running in fallback mode in Basicui

I keep having this black bar appear at the bottom of the basic site map page.

[SSE subscription failed: running in fallback mode]

Ive searched around, and all the articles where this error is happening don’t seem to apply to me. No reverse proxy etc.

Openhab 2.5 is running on a Pi 4, happening in chrome and safari browser running on Mac book. The error persists even if I remove all but 1 item in the site map.

Any ideas?

Try cleaning the browser cache and restarting OH.

You can also try stopping OH, cleaning cache, and restart OH a few times.

sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo systemctl start openhab2

Then after OH has completely restarted use sudo systemctl restart openhab2 give it time to fully load (watch the logs) then run the command again.

I’ve also seen this happen if you have a bogus binding in your addons.cfg or addons.config. But, if that were the case, you would see installation failures reported every minute in your log file.

The problem seems to have gone away by itself. Thanks all for your advice will revisit should it reoccur.


FWIW, I had some similar error messages both in the Basic UI and the new Main UI (OH3) today in combination with 401 errors from the REST API, and I could resolve these problems by turning on the basic auth + implicit user roles settings under API Security. Hope this may help someone else :slight_smile:

1 Like

Turning on the basic auth is not required on a standard setup. You probably do not have a usual setup or you have another problem.

You made my day :crossed_fingers:

1 Like

Your hint solved my problem!


What me helped:
Clear the Cache

For me, the problem was that my browser (Safari) somehow still used old credentials for Basic Auth. Unfortunately, deleting this data is not so easy, but I was then able to do so by simply calling the URL with incorrect credentials. Something like After that i could call the correct url and login without any problems.