Ssh connection to karaf no longer possible


i noticed that i can no longer connect to the console via ssh -p 8101 openhab@localhost.
i already am at the computer that is running openhab.
it worked fine but it stopped working for 2 weeks or so now.
after upgrading to M5 it shows the same issue.
my console plots:
connection refused.

what can i do here?

thanks a lot!

I believe the Karaf version was updated.It might be a good idea to open an issue on GitHub.

1 Like

I had the same problem after upgrading to M5, a restart of openhab solved it!

1 Like

Thanks. It also helped for me.
After the reboot i had to edit the known_hosts file but now it is working again.

Where is that file?

The console plot a warning with the path. For me it is users/user/.ssh/known_hosts

That file does not exist when connecting locally with openhab-cli console.

I have a Mac. I do not know the path on linux. Do you have a problem at all? What does the console say when you try to connect?

openhab@debian-01:~$ openhab-cli console

Logging in as openhab

So everything seems fine. Can you connect normally? If yes you should not have to edit the file

No, before Milestone 5 that command went directly to the Karaf console prompt. No password entry needed.

I do always have to type in a password. There is another file where you can save them. At least i think so. Maybe you can google it.