SSH on RPI stopped responding

On RPI 2, my ssh stopped responding after several months of working fine.
Currently, when trying to ssh via putty I only get a “Network (reboot)!” warning. Tried also to use using KiTTY and immediately get “Server unexpectedly closed network connection”.

Tried to connect a TV via HDMI but cannot see anything on screen although the openhabian seems to work just fine.

All passwords are the default. How can I reenable SSH?

You may want to try a USB keyboard and use the linux ALT + PrintScreen + REISUB key combination to gently reboot it. After that, SSH may work.

If not, and assuming you’re running systemd, if you can connect it to a screen, you can use

sudo systemctl status ssh

command to see if it’s running. If not, try

sudo systemctl start ssh

In my experience on a Pi 2, network hangs are not uncommon, and this is what’s happening (guess). You may want to look at setting up a watchdog timer so it automatically reboots if it loses, for example, a ping connection to your router over some period of time.