SSL Handshake Failed with Openhab Android App and Openhab Cloud


Please I need help to solve the problem of connection between Openhab Cloud Connection and the Android App. I have many Android mobiles most of them are working perfectly but I have 2 of them not.

I read many topics regarding this issue but all are talking about a private cloud, but for me, I am working on cloud.

Please advise !!

Did you Setup all the device the same way? Especially, did you set something for the SSL client certificate for the devices in questions only?

Hello Opus,

Yes all devices are set in the same way, i did clear the data of the App and tried again also not working. Even i tried to connect the same mobile to different Openhab controller with no success. and i didn’t touch the SSL client Certificate in the settings.

Every time the SSL handshake failed noting that in the Openhab App settings is hows that it’s connected to Openhab cloud.

What “different openHAB controller”?

i have 2 homes with 2 different Openhab servers. so i tried the App on both on the same mobiles are not working.

Is there any difference between the Android versions ?

well the working ones are Android Version 7 and 9.

the non-working mobile has the Version 8.

and also and also i have another mobile with Android Version 10 not working.

Any advise what could be this issue from ??

The certificate that’s being used on server is created by Lets-Encrypt so the certificate shouldn’t be the root cause.
Do the Android mobiles that do not work have something in common compared to those that work e.g. like from a different vendor ?
In the app under settings there are two entries ( last two ) ‘show information related to solve problems’ and ‘protocol’. Could you try them if they provide more information that could be used for the analysis ?

Actually not related to the vendors cause the ones working are Samsung & Huawei and also the non-working Samsung and Huawei.
here is attached the exact message that appears on the non-working mobiles noting that the username and password are 100% correct.

Here is also the message from another mobile:

could you also check if there is more info in the ‘show information related to solve problems’ and ‘protocol’ menu of the app ?

hello, did it and nothing additional is shown.and here is another message appears on the same mobile but using this time the Beta version of Android app. am not able to understand if it’s a mobile issue or Openhab issue. this never happened before and it happens with many mobiles and not only one.

any advice on how to debug / further track this down ?

Which app versions do you use? Please make sure it’s 2.14.0 or a beta release of 2.14.X.


Exactly I am using the laster one 2.14.0.

Are you using the same username and password combinations on all devices?

Strange, maybe there’s something wrong with the SSL stack on your device. Is it rooted or modified in some way?

This is just a timeout. Did you retry it?

Hello Mueller,

First yes I am using the same combination of username and password. moreover, it shown in the app settings that I am connected to Openhab server.

Second: the mobiles are not rooted.

Third: I keep retried it, even I cleared the cash of the app then uninstalled it then installed it, after that being stuck on the same step.

for now I am using the basic UI logged in via the chrome browser in the mobile then I created ashurtcut for the remote page of the basic UI. it’s working normally. but the native mobile app still not working remotely.

Can you post the log of the devices?


Finally, the problem has been solved, it was the automatic backup of the Data apps inside the settings of the mobile. it should be turned off and clear all the data then reinstall the app.