Stability of myopenhab & google home for everyday use

Maybe not you. Maybe your internet connection, maybe your ISP connecting to the servers in Germany
There could be plenty of reasons

Not at all.
Just telling you my experiences.

All three issues could be down to the connection from you to the cloud. I find it very strange that you even experience slow connection to myopnhab website.
I have no idea how you would investigate this… But the picture seems to be due to connection problems between you and the loud, problems I dont experience, which could be the reason why it works for me.

Unfortunaly there is no way to debug this, as far as I know… I know @matt1 said something about this debugging a coupple of months back. But I have no idea if he managed to get anything going.

The main issue I have is that if the cloud goes down your instance is sometimes considered to be offline while it is online. So you need to manually restart the Cloud Connector bundle or openHAB to resolve it. :cry:

See also:

I have not had this issue at all.
I can tell from the log, when openhab starts, it connec to the cloud. Sometimes I see it disconnect right after, but it connects fine again after a few seconds.
I use the cloud connection together with Google Home every day, at least a coupple of times a day, cause I tell Google to open/close my garagedoor when I arrives home or leaving :wink:

Try doing a ping with a large MTU size and see if you get packet loss. A normal ping is not good enough, it has to be the special ping in this post. Note how long the ping takes as there was a note in the source code about very low pings…

Also a 2-4 second delay is normal for me from when I ask to when the light changes. However it is very reliable and always works here now my problem is sorted. If I ask google to set an alarm or reminder a similar amount of time passes and this does not use Openhab or its cloud to set an alarm.

“OK google set an alarm for 1 minutes time”

Two links to use for fault finding are:

The binding uses this address to GET your items from. This link MUST work and return your items. If it does not or it is corrupt you will need to fault find why…
Replace openHABianPi with your IP address if it does not work…

This link should do the same thing but via the cloud.

1 Like

Thanks everyone for help

For now everything works like a charm.

What i do:

  1. Fully uninstalled mosquito and openhab2
  2. Freshinstalled both
  3. Made a propper clean config with files. (Migrating MQTT1 items to MQTT2.4 items)

Now cloud is working fine.

Do not know what was the reason, meaby some temporary cloud problem or my temporary isp problem.

@vzorglub i should have a good connection to germany i live in poland
@wborn Yes this is a big issue, lets have hope it get fixed.
@matt1 both sites are now accesible, will check MTU latter

It doesn’t really matter really. A bit. I suspect your ISP was at fault in this case

just to add my two cents. I cannot confirm the free service is VERY stable. It’s stable, in deed, but sometimes my google home tells me openhab is not reachable. Happens rarely, but it happens.I would rather move to a payable service in order to achieve a more stable connection.

@ StefanHStefan Haupt
yes, i still have sometimes like 1 for 20 uses that openhab is not reachable.
in my oponion the creator of the cloud should make a premium service on differen less loaded server.
this would help us and the development of the project with extra money

If you (and others) are willing to pay for an improved experience, then perhaps rather than make multi-tiered, paid access levels (and add to the maintainers’ already heavy load), we should all consider donating to the project, or even joining the openHAB foundation for a more regular financial support. I bet if more users did this, the maintainers would be able to scale up the service, and benefit everyone.

Its a good idea… However, joining the foundation is not a simple and easy task in my opinion. It actually require something most people wouldnt normally accept. And it´s really sad cause I believe alot of people would donate if it could be done in a more suitable way.

Another option is to host your cloud yourself. I think there is a guide somewhere here in the community to do so. But it wont do much good, if the internet connection is the reason to blame. The cloud still need a stable connection.

the google home action is not supported with a self hosted cloud. so if you want your google home to control devices managed by OH, you are forced to take the official openhab-cloud. Writing your own google action is not a real alternative.

HI - I’m new here. I’ve been using Openhab2 for a few months now. Thanks to all for the great work on this project.

I have been experiencing the same concerns in this thread. I can live with the few seconds delay sometimes when asking Google Home to turn something on or off, but the “can’t reach Openhab” thing is a bit more of a problem.

My take on this is it is not a problem with my Openhab setup or my ISP Internet connection. The reason I say this is because Google will take 10 or 15 seconds and say it can’t reach openhab, but then the action I requested will still happen, maybe many seconds later. This indicates to me that Google is timing out waiting for Openhab to acknowledge the request (Google will wait 5 seconds, this I know because I have written Google actions). However, Openhab has obviously received the request and executes it it since it eventually works which indicates latency in the pipeline, rather than broken connectivity issues.

I also see fairly frequent connection drops and reconnects with the cloud service in my Openhab personal server logs. These usually last 30 seconds to a couple minutes. They don’t correspond to any known internet connectivity issues in my house (1GB FIOS connection). They also don’t seem to correspond to times where I’ve had the “can’t reach Openhab” issue.

I moved from HCA to Openhab2 to get more devices supported since I am moving off of X10. I never had this latency problem with HCA, the response from Google requests was always pretty much instant. The only difference in configuration was that HCA was running on my same home server but using HCA’s cloud rather than Openhab’s.

I understand this isn’t a “support forum”. However, we are using a service, and if we rely on it to control our home we need a way to get “support”. I don’t know what that means. I would be very willing to pay $ for the service to be able to get support, or at least ensure that the service is being supported. I would also be willing to contribute my time to help the implementation of the cloud service.

I’d like to do more than just shrug about this. I’ve been doing some cool things with Openhab I’m getting ready to contribute to the community, but if I can’t get a reliable operation I can encourage my wife to use I am going to be forced to move my development and implementation efforts and time to another platform.

Yes, I’m seeing this as well - not every day, but maybe once every second week I get google reporting that it could not reach openhab right now. Sometimes the command still works. My internet connection is not something I’d consider be part of this problem, since I never have issues anywhere else (1Gbit fiber, and high throughputs, and I’m in Europe). My assumption is the workload of the oh cloud servers time to time is casuing this. But I have no clue if this is the true cause though. Most times, the google commands are surprisingly quick. Also I would not mind paying a fee if it helps.

so, it’s Aloha to Openhab. I really liked the project but the cloud and voice control are just too unstable. This thread got no responses beyond the snarky “this ain’t a support forum”. Gotta have something reliable so I’ve migrated to HASS and that seems Great. Worth 5 bucks a month to me.i’ll bring my development efforts there, including my Tuya service I wrote.


Sorry to hear that you didn’t get any responses. I wasn’t a member of the community in January, but I would have tried to help if you had bumped the thread more recently. Others who missed seeing it the first time around might have also chimed in.

I also get disconnects from myopenhab in my log and I’ve seen it discussed in a few threads, but Google Home has never been particularly slow to respond for me.

I agree that it’s probably better for you to pay for HASS, and I hope it comes with the features, stability, and support you need. I’m sure your development efforts would have been appreciated and encouraged if you had discussed them in the OH community, but I guess we’ll never know. You’re always welcome back if you change your mind, though.

1 Like

I recommend using openhab cloud privately. I run it on the same server as my oh2 instance. It’s a pain to setup (or can be) but it’s been rock solid since install. Nothing against the myopenhab but prefer the control locally.

Thanks for the feedback, but what else do you need to consider before making that change? I have looked and I remember I saw you need to pay a monthly fee for a certificate of some kind? oauth2 or SSL? Any free ways to get it running locally?

There has been several other threads about the issue in quite some time. This could be the reason why this specific thread hasn´t been answered.

I use myopenhab/google home almost daily. My experiences is, that its fairly stable. There are a few hickups now and then, but mostly its running just fine. When there are hickups, I´ll just repeate the command, and then it works.
Granted, I would love it to be rock solid ofcouse. But I think this feature is having several places where it can go wrong, beside openhab, so I dont think it´ll ever been rock solid like in 100% perfect. I would assume the very same for HASS and any other system using google home/assistant voice commands.

Good luck to you!

Matt, there are no fees. Lets Encrypt SSL Certs are free, just setup a crontab to renew them every 30 days. Works well.

1 Like