Stale link in SmartThings binding document

In the document at Samsung Smartthings - Bindings | openHAB, there is a sentence that says " thingTypeId (opens new window) corresponds to the “Preferences Reference” in the Smartthings Capabilities document"

That link just gets redirected to a generic Samsung page. I think the URL should be Capabilities Reference | SmartThings Developers.

You can submit an edit to the documentation in GitHub.

I tried to submit an edit but got permission denied (403 error). Here’s what I did:

  • Cloned the repo
  • Created a branch
  • Made the edit and committed
  • Generated a Personal Access Token
  • Tried to push to my branch with git push --set-upstream origin Fix-link-to-capabilities-list

Do I need to become an authorized contributor?

I don’t think so. @Confectrician, can you help with this?

You have to fork the repository (basically this is a “local” copy of the repository in your github account) and make changes over there.

In your fork you have all needed acceses.
After editing and pushing the code to your repo fork you can then start a pull request to the openhab repository, which then gets reviewed and merged.

1 Like