Starting with InfluxDb

I’m trying to get InfluxDB running on a Rasberry Pi2 with openHAB 2.3
I already installed the InfluxDB Persistence (v1.0) Add-on from the Paper-UI

How can I start the influxdb service or how can I access the mentioned influx webinterface ?
I used SSH to start the influx cli, but the ‘Unit influxdb.service’ is ‘not found’

Good story, but it doesn’t help me.
Somehow, I can’t get the Influx commandline.

it does help you since it includes a link to

obviously, you didn’t follow the instructions

Hi. I am following the installation instructions at

I get this after starting the service, apparently successfully

[21:24:40] openhabian@openHABianPi:~$ influx
-bash: influx: command not found

Likewise no response via the web service interface.

I noticed in a thread in the influx community that the following need to be run:

test $VERSION_ID = "7" && echo "deb wheezy stable" | sudo tee /etc/apt/sources.list.d/influxdb.list
test $VERSION_ID = "8" && echo "deb jessie stable" | sudo tee /etc/apt/sources.list.d/influxdb.list
test $VERSION_ID = "9" && echo "deb stretch stable" | sudo tee /etc/apt/sources.list.d/influxdb.list

I assume I am supposed to run just one of these however each one yields the following:

-bash: test: =: unary operator expected

Or if preceded by sudo:

[21:47:50] openhabian@openHABianPi:~$ sudo test $VERSION_ID = "7" && echo "deb wheezy stable" | sudo tee /etc/apt/sources.list.d/influxdb.list
test: missing argument after ‘7’

I cannot find any reference to this error in any blog. Can anyone help please?

I think the command line doesn’t work or something right now, anyhow, here is a link to where I got stuck on the same thing and figured it out

I also tried to install InfluxDB last weekend and ran into issues. Seems as if the script in openhabian-config isn’t working properly right now. I haven’t had time to take another look at it, yet.

Thanks. I am not sure this is an openhab related issue. I feel sure it will be solved once I understand what is going wrong with

test $VERSION_ID = "9" && echo "deb stretch stable" | sudo tee /etc/apt/sources.list.d/influxdb.list

Maybe I will log in the influx forum.

Replying to my own post. I have now solved this. It is important to follow the instructions on this thread:

precisely. In my case I failed to notice that there is a different procedure for installing influxdb on a RPi. The link is:

After that I have no problems except that the instructions for the embedding of a grafana chart into a sitemap aren’t quite right. I will post another update on the main thread to correct it.