Status updates for Qubino Relays/Dimmers generally do not work

But you don’t get reports if you change the dimmer at the switch I assume? Only Dimmer updates through the associations right?

If you use FF then the device will return to the last value - this is configurable in the channel configuration.

Because it is not required - you can just use the dimmer channel. It should use exactly the same commands as the switch channel if you use a switch.

My experience with FGS223 is very good. I am running 12 of them and the response speed of status updates is nearly immediately (max. <= 1 sec.).
There were also problems with the endpoints about a year ago (you can find the discussion here in the forum) similar to the Qubino problems. The problems were then solved and when I included them via Habmin network wide inclusion everything worked fine (but this was months ago). There are however some reports here which indicate that at some stage the dev binding had a regression so I am not sure how they will work if you include them with the most recent dev version.

The strange thing with all these problems (Fibaro FGS223 und Qubino ZMNHBD) ist that they were all already solved in the first half of 2017 and from then on my devices all worked fine (reporting status changes on swtich1/2, power 1/2 etc.). But it seems that I was lucky to include them with a binding version at the time which made them work (although I do not understand why this makes a difference).

sorry, actually it is not working with Dimmer1. I changed from switch_dimmer to switch_dimmer1 in the items file, but actually it only added the link between item and switch_dimmer1 channel - the old link was not removed so there was two links. I had to comment out the item definition to remove all links and then add it again.

Yes, and I have set it to “restore last value” but the actual behaviour is different. Instead of setting the last value of 100% it sets the dimmer to 50%. And if the last dimmer value was at 50% then it sets the dimmer to 30%. It only works like that if i turn off manually and turn on remotely. I can send you the debug log.

Actually no. As I wrote, there are two dimming times, and one dimming time is used with switch channel and the other dimming time is used with dimmer channel.

Maybe this is a device setting? If the binding is sending FF, then I don’t think it can be a problem with the binding…

Yes, but this is not the point. The binding should send the same commands if you send a ONOFF type to the dimmer channel. It’s not currently configured this way, but that’s how it should be configured.

I’d like to try out the latest changes you’ve made, @chris. Just to be sure, is this were you put the latest development builds for the Qubino changes?

Yes, but please refer to the following thread as installing is not as simple as with the master binding -:

The top 6 or so messages are relevant for installing…

@vossivossi i just fully reset my zwave stick of my test environment and added the latest dev binding for ZWave.
re-included the fibaro 223 and my qubino flush 2 relay, which was reporting the status with the earlier binding.

fibaro working perfectly, but qubino is now not reporting any status.

Please provide a log and I will take a look.

Chris, I am sorry to report that using the Dec. 30th Build, my firmware 1.1 version dimmers no longer report state back to openhab.
I have tried all the “tricks” that worked when this was “fixed” some time ago…

Please provide a debug log and I’ll take a look, but also check (if you haven’t) that no channels are working… By this, I mean check that neither the dimmer, or dimmer 1 channels are working.

Hopefully tonight I’ll update the binding and I’ve updated the dimmer to remove some channels to avoid some confusion - let’s see if that helps or makes things worse :wink: .

I’m just going to do one last test and delete the xml:s and restart the binding, and also test to manually re-set the associations.

I created a ticket and uploaded a log, ticket ID KBXfmTkhQ9P.
5 dimmers, two are reporting back. 3 does not.

Thanks - I’ll take a look.

@rozpruwacz the latest update now removes the switch - if you send an on/off command, then it should send exactly the same command, in exactly the same way as the switch channel (it goes through the same converter still). Please let me know if you have any issues - I only did a quick check to make sure that the binary_switch command was being sent, which it was…

Sorry Daniel, but the log doesn’t have the initialisation as the device was presumably already initialised and it just loaded the data from the XML

Maybe the thing to do is to use the latest binding that I just loaded an hour or so ago so we have a known starting point. The after initialisation has completed and everything is settled, use HABmin to reinitialise the device - this is in the menu in the top right corner once you select advanced mode.


Try this with one device that doesn’t work…

Also, I assume when you say that the device doesn’t report status that there is nothing in the logs?


Hi Chris,

I just did it with one of my not working ZMNHDD Dimmers (node 160).

The log should show the moment from clicking ‘Reninitialise the device’ in Habmin until the end of (re)initialisation (00:06:30 to 00:06:40).


Thanks Martin - that’s useful. It’s showing the database change I made hasn’t had the desired effect. I’ll take a look at this tomorrow.

The dimmer you sent me already says it supports multi-channels - do you know if there’s a way to completely reset the Qubino dimmers? I’ve not found it in the docs.

I just found this section in the docs:

So pressing the button 1 5 times within 3 seconds (in the first 60 seconds after repowering the device) should do the trick.

1 Like

ok, I’ll try that. Now I understand what You mean :slight_smile: I mixed up concepts of channel and command class.
BTW. I think i broke my dimmer … now, when i turn off the light from 100%, it sends couple of reports like 80%, 50%, 20% and lastly 0%. And sometimes it does not send the 0% report and openhab thinks that the light is turned on … :frowning:

Sounds also like a parameter soft dimming.

There are parameters for that and aswell for max and min dimming values. I think you played too much there :wink:

I have set the attribute “60 – Minimum dimming value” to 10 and “61 – Maximum dimming value” to 50. Other parameters are default (I think). what parameter number are You refering as “soft dimming” ? Mayby i’ll just reset the dimmer :slight_smile: