Status updates for Qubino Relays/Dimmers generally do not work

Yes the only old device that works are flush2 units, flush1 and flushdimmer did not
when i tried to include a new device flush1 it works and the new flushdimmer works

@chris, did You have had any time to look into the ticket I created (and does it contain the relevant information)? Seeing as @Daniel_Linder sees the same thing, at least I’m not alone.
My node 79 is still stuck at ‘ASSOCIATIONS’ so something is the matter here.

Sorry, I forgot to reply on this. Your log didn’t really have anything much in it for this node.


I see a bunch of TIMEOUT_WAITING_FOR_CONTROLLER but I’m not really sure why since there doesn’t seem to be any messages being sent to the device at all.

Is there anything else to try?

The lines looking like this, I thought looked suspicious;

13:55:06.953 [DEBUG] [ialization.ZWaveNodeInitStageAdvancer] - NODE 79: No data from device, but it was ACK'd. Possibly not supported? (Try 4)

Looking in todays log, there’s only

2017-10-13 14:53:06.957 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 79: Polling...
2017-10-13 14:53:06.957 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 79: Polling deferred until initialisation complete

Does this mean that the binding is waiting for the node to send something? NIF?

But no data is being sent, so of course there is no ack :confused: . Maybe the log doesn’t have everything, but as I showed above, in the log you sent me there is no data at all being sent to node 79. I don’t know why this is, and there are strangely long gaps of no data in the log - maybe there’s an exception logged somewhere else, or I don’t know, but from what I see in the log, I have no ideas of what is happening - sorry.

OK. I’ll copy the old xml back, and hope someone else gets better logs.

The gaps are (space lines) are what I removed, in order to get more lines of node 79, so that is not a mystery. :slight_smile:

Ok - did you remove any receive/transmit data lines? For me the mystery is why there is no data being sent to, or received from this device in the logs you provided…

No, I removed nothing that was addressed to/from this node during the period of the log snippets. After a few hours, I used the toilet ( :slight_smile: ) where it located, but that was after, time-wise.
I can restart OH tomorrow to re-init the process of finding node 79, and keep all logs from scratch. Can update ticket.

Ok, yes, please provide the “full” startup log (up to 10MB) attached directly. If it stops sending again, then hopefully we can then see why/where it stops.

I have quite a lot of z-wave devices, amongst others 5 Qubino dimmers, 3 Qubino flush (2) relays, 1 flush shutter.
My plan was to migrate from from Vera to Openhab. Have done it in steps. There has been no major issues with most devices - however, the qubinos are killing me…
On the stable 2.1 release, the dimmers were working fine and items were updated when the wall switch was used. The flush relays have never worked, regarding status feedback.
At the moment i am running the lastest (Oct 14 develop z-wave binding) and the latest openhab snapshot. To be honest, with this setup None of the dimmers or relays does proper statusreporting to the controller. trying to set the lifeline for the controller for one of the dimmers (node 7) results in the following log entry:

017-10-15 15:06:06.697 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 7: Configuration update group_1 to node_1_0

2017-10-15 15:06:06.700 [ERROR] [st.core.internal.thing.ThingResource] - Exception during HTTP PUT request for update config at ‘things/zwave:device:15e9af154ac:node7/config’ for thing ‘zwave:device:15e9af154ac:node7’: null

I have no clue what more I can try, or should I have to replace my Qubinos. (or revert back to Vera for the z-wave)

Firstly, with the latest version you are running the lifeline should be set as part of the initialisation of the device - completely independently of any user interaction. Please reinitialise the device, and if it’s not working, provide the log so I can take a look.

The error you report is a problem at the moment, but I can’t find where it is as the debug information is not of any use. I believe that this is happening outside of the binding, but I can’t reproduce it here, and logs like you provide don’t help me find the issue. I’ve created a PR in ESH to try and log better information, but it’s still pending.

Many thanks to you Chris for you efforts and all the work you put into the z-wave binding. It is much appreciated!
As a “long time lurker” - I have been following all qubino threads, hoping it will be resolved sooner or later. I am aware that the lifeline should be set automatically. But at least for me, it does not.
I will send some logs to you (as soon as I figure out how to get a separate zwave.log file…

Thanks Daniel,
Don’t worry too much about creating a separate ZWave log - assuming you don’t mind me seeing whatever else might be in there. The log viewer I use will filter out the ZWave entries… If you like you can create a ticket on my site and you can then upload the file to that (up to 10MB is fine although a bit bigger can be okish…).


Created a ticket on your page, and attached a log.
I tried your log viewer, but am not skilled enough to actually draw any conclusions from that. ;-/

Any progress on the Qubino issues?

Sorry. Be been on holiday for the past week - heading home tonight so will take a look over the next days.

Please use the latest version that I’ve just posted and if (probably when) it doesn’t work, please send me a complete log of the startup. You must reinitialise the device, so either delete the XML before restarting the binding, or, wait until things have initialised, then use the “reinitialise” option in the thing menu to perform a reinitialisation.

I’ve added a bit more debug into the binding so hopefully this will help me see what’s happening.

Hi Chris,
Followed your instruction.

Node4: Living Room Ceiling light: Qubino Dimmer Zwave+
Node7: Lounge Ceiling Light: Qubino Dimmer Zwave+
Node24: Kitchen Ceiling Lights: Qubino Flush 2 relay

xml:s deleted
Nodes re-initialized

Openhab restarted 17:12

Nodes 4 and 24 seems to intialize correctly.
Node 7 is stuck at “initializing endpoints” in Habmin.
No xml created for Node 7.

Node 4, 7 and 24 has full functionality from PaperUi.
None of the nodes updates status in openhab when the “hardware inputs” are used.

I created a ticket and uploaded a log to

Thanks. Unfortunately the log seems to start after the initialisation is complete (sorry).

Ok. I see. The log rotation must have happened right at that moment… :tired_face:
Will do another try. Sorry for that.

1 Like