Steinel 140 pir

Running OH 2.2.0 with a Aeotec usb zwave stick. And trying to ADD Steinel 140 pir, gets added but it dosent seame to work correctly, like the lux sensor doesn’t show anything.

Any tricks or tips

The database entry is not correct, try editing the missing/wrong parameters.

It looks like this

Upload the xml file to the database or post it here …

node8.xml (26.5 KB)

Because there are already entries in the database for that device it won’t let me upload the new xml file.
I have created a ticket to take care of it. As soon as the maintainer has time to finish this I will post an update.

1 Like


Any updates?

Nope, check it:

Hi @sihui - I replied to your ticket on the 8th May… What needs to be done with this?

Sorry, don’t know what went wrong. When I took a look at the ticket three days ago I did not see any replies. Did not get any notifications either (nothing in SPAM), even not when opening the ticket.
Maybe some travelling issue, I’m not at home at the moment.

Anyway, the endpoints are a mess, I don’t think those will work for any user …

Device definition contains errors

    Channel in endpoint 1 command class SENSOR_ALARM has no name!
    Channel in endpoint 1 uses an unsupported channel ()!
    Channel in endpoint 1 command class SENSOR_ALARM has no name!
    Channel in endpoint 1 uses an unsupported channel ()!
    Channel in endpoint 2 command class SENSOR_MULTILEVEL has no name!
    Channel in endpoint 2 uses an unsupported channel ()!
    Channel in endpoint 3 command class SWITCH_BINARY has no name!
    Channel in endpoint 3 uses an unsupported channel ()!

These errors must be removed before the device can be approved

As there is no easy way to just remove only the endpoints I could try to manually edit them according to the above xml. If it does not work we probably need to scratch that whole thing and readd it.
I will first try to edit manually, depending on my internet connection speed today, but latest on the weekend when I’m back home.

Can you still not see the reply on the ticket? Strange if that’s the case as I’ve not changed anything since I wrote it …

If you can reply to my question on the ticket I can also give you admin access on the database and I can also (myself) go in to the database via SQL and delete the endpoints if needed?

I’m also travelling at the moment but will be hope tonight so can update then.

Nope, I can see it now :sunglasses:

I did three minutes ago.

Just in case there’s an issue with responses from the ticket system, I’ve updated your access in the database…

1 Like

Thx, have a couple of buttons more now.
Will work on the Steinel issue this weekend, hotel-wifi is weak …


I’ve updated the device to my best knowledge.
As soon as the changes have made it into the binding please report back.

It would be great to have some feedback on the individual channels to see if there are maybe too many included.
I’m pretty sure the scene_number has to be removed :sunglasses:

Sure, do i place it in addons or ?

Yes. First uninstall the zwave binding from PaperUI, then download the jar file and place it in your addons folder. A restart of openHAB may be needed.
Then check via karaf and bundle:list|grep -i zwave if the new version of the binding is active.

I’ve been following this thread as I also have the Steinel 140.

It still doesn’t seem to be working for me though, I’m running version of the ZWave binding.

Is there any info I can provide which will help?

Thanks for your efforts with all of this :slight_smile: