Stop the ZWave USB Stick Disco

I have an Aeon Labs Gen5 USB stick as my Z-Wave controller. It works, and I have control of the devices on the Z-Wave network. I’d like to stop the color changing light on the controller from flashing through each color - it’s doing this constantly whenever it’s plugged in.

I think I just need to set a Z-Wave config parameter (81, which is in the DB https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/265 ), but I don’t see how I can do that with the items I have. I’ve tried this in both 2.3.0, and 2.4.0 nightly (I also followed the directions to remove and re-add the binding and devices on upgrading to 2.4.0).

Interesting things I’m noticing (which may or may not be related to my question):

  • The parameter, 81, is in the Z-Wave database

  • The manufacturer and device ID noted in node1’s xml file match the Z-Wave database

  • I do not see a “Thing” for node1, only a generic “ZWave Plus USB Dongle”, and that has no parameters available other than Z-Wave network configuration.

  • My devices start at node4 (there is no node 2 or 3 on my network, only 1,4,5,6,7)

  • I am not able to load the Z-Wave network diagram in Habmin - it’s blank. This was working in 2.3.0.

  • Platform information:

    • Hardware:
      • Freescale i.MX6 Quad/DualLite (Device Tree) (4-core, ARMv7)
      • MemTotal: 2063248 kB
      • MemFree: 226008 kB
    • OS: Debian 8.11 (Linux linux 3.14.79-fslc-imx6-sr #1 SMP Fri Oct 20 18:16:19 UTC 2017 armv7l GNU/Linux)
    • Java Runtime Environment: OpenJDK Runtime Environment (Zulu Embedded 8.25.0.76-linux-aarch32hf) (build 1.8.0_152-b76)
    • openHAB version: 2.4.0~201811041348 (installed from deb package)

Things:

node1’s xml file:

<node>
  <homeId>REDACTED</homeId>
  <nodeId>1</nodeId>
  <version>4</version>
  <manufacturer>0x86</manufacturer>
  <deviceId>0x5a</deviceId>
  <deviceType>0x101</deviceType>
  <listening>true</listening>
  <frequentlyListening>false</frequentlyListening>
  <routing>false</routing>
  <security>false</security>
  <beaming>true</beaming>
  <maxBaudRate>40000</maxBaudRate>
  <sleepDelay>1000</sleepDelay>
  <associationGroups class="concurrent-hash-map"/>
  <endpoints class="concurrent-hash-map">
    <entry>
      <int>0</int>
      <endPoint>
        <deviceClass>
          <basicDeviceClass>BASIC_TYPE_STATIC_CONTROLLER</basicDeviceClass>
          <genericDeviceClass>GENERIC_TYPE_STATIC_CONTROLLER</genericDeviceClass>
          <specificDeviceClass>SPECIFIC_TYPE_PC_CONTROLLER</specificDeviceClass>
        </deviceClass>
        <endpointId>0</endpointId>
        <secureCommandClasses/>
        <supportedCommandClasses class="concurrent-hash-map">
          <entry>
            <commandClass>COMMAND_CLASS_NO_OPERATION</commandClass>
            <COMMAND__CLASS__NO__OPERATION>
              <version>1</version>
              <instances>0</instances>
              <control>false</control>
              <versionSupported>1</versionSupported>
            </COMMAND__CLASS__NO__OPERATION>
          </entry>
          <entry>
            <commandClass>COMMAND_CLASS_BASIC</commandClass>
            <COMMAND__CLASS__BASIC>
              <version>0</version>
              <instances>0</instances>
              <control>false</control>
              <versionSupported>0</versionSupported>
              <isGetSupported>true</isGetSupported>
            </COMMAND__CLASS__BASIC>
          </entry>
        </supportedCommandClasses>
      </endPoint>
    </entry>
  </endpoints>
  <nodeNeighbors/>
</node>

I have no idea how to solve this with “openHAB tools”.
The Backup Software from the manufacturer worked for me. Unfortunately, the software only runs on windows.

Same here for me. The Z-Wave Stick from Aeotec gives Disco light which is extremely annoying at night when it’s in the sleeping room.

In Domoticz I remember I could turn it off, but in OpenHAB I don’t find the parameter. @chris do you have any idea how to achieve it or does this need an update? I am running OpenHAB 2.4.0 stable on Raspbian (not OpenHABian).

As far as I know there isn’t any way to turn it off from the host side, but I could be wrong. Some time back (ie a few years ago) I made enquiries about this and was told that the controller doesn’t respond to local commands.

Hello @chris,

I found the option in Domoticz. This allows me to deactivate the blinking disco light (screenshot - last option “8. Enable Controller Blinking”):

Is that doable in OpenHAB as well?

I have no idea. I can easily make an option on the screen that says the same thing, but since I don’t know what to actually send to the device, it won’t do anything :wink:

You could try it through a serial port directly

1 Like

Thanks for the link @sihui.

This seems to be a custom serial command implemented by Aeon so it’s not super easy to add this to the binding. I’d need to think about how to architect this in to the binding, so for now I suggest if it can be done manually, then it is best.

1 Like

@chris - thanks. I’ve done it through Domoticz. For anyone who’s interested how to quickly do that on the current OpenHAB machine, here’s how I did it on my Raspberry Pi with Raspbian.

First, you have to stop OpenHAB. Then execute the following commands (I assume you are root):

adduser domoticz
gpasswd -a domoticz tty
gpasswd -a domoticz dialaut
su - domoticz
wget https://releases.domoticz.com/releases/beta/domoticz_linux_armv7l.tgz
tar xvf domoticz_linux_armv7l.tgz
./domoticz --www 8080

Then go to your web browser and call http://<your_openhab_machine>:8080 - There you are in Domoticz. Go to setup and add the Stick as “Open ZWave” device. Then you can configure it and disable the blinking light.

Once you’re done go back to the Linux console and press CTRL+C to stop Domoticz. Press CTRL-D to become root again and start OpenHAB. Your disco light should be gone.