Strange behaviour of Fibaro Flood Sensor with Razberry and OpenHabian

The problem appears to be in the database definition - there are two channels linked to flood. I’ll delete the sensor_alarm class.

How to delete class, what does it mean?

BTW I’ve noticed that there are two Flood Sensor Alarms items in Flood sensor definition - right now I have no access to my installation and I will send you screnshoot later.


That’s exactly my point - I’ve removed one of them.

Ok I will try it later. But as I understand it is another bug - I’ve noticed this two Alarm definition each time when I add Flood Sensor to Openhab.

Well, it’s related. It is why you are getting two updates.

If you use the latest binding as suggested earlier and not the release version then I think the problem will go away.

I hope last question, where can I find latest (snapshot) binding?
I’ve found this

is it ok?

No - that’s the OH1 binding.

The OH2 binding is here -:

Note that if you’re installing manually, you will have to handle the serial driver dependancy by also installing this.

1 Like

I see Z-wave binding but I cannot locate serial driver? Has it different name?

Good question - I suspect it’s in a different repository unfortunately.

Easiest is actually to install this through Karaf console with the following command -:

feature:install openhab-transport-serial 

Does it install serial driver using latest snapshot? Probably from release, how to switch to snapshot?

I’m not sure, but it won’t matter (I think!) as I don’t think it’s changed recently - I would try it and see what happens.

Also, if you are using other binding that use the serial driver, then you don’t need to do this.

Ok. thank you I will try.
I have to say that I’m little suprised that such bugs (we can define as High or Blocker) exist in the release version of OpenHab.
I wonder if similar problem encounter Domoticz users :slight_smile:

Sure - ALL software has bugs. Until someone finds them, they aren’t fixed…

In this case, I guess no-one has used this device, or if they have, they didn’t report it so that it can be fixed and I personally don not have every Z-Wave device to test agains :wink:

I tried to delete, but I do not know how to do it? There is no delete button near "Alarm (flood), I can delete linked item but when I delete one item in one “Alarm (flood)” in the same second link automatically is deleted :frowning:

The channel needs to be deleted from the database to completely remove it (which I’ve already done). To stop it doing anything, just unlink it.

Ok but when I unlink whole logic will not work. Unlinlk one item
automatically unlink second.

In paraller I’m trying to replace old binding to

I’ve found such directory


and there is org.openhab.binding.zwave-2.0.0.jar

should I delete old jar and put new one? Is it enough?

Ok - then unfortunately you need to wait for the binding to be updated. At the moment builds are not working so there is no update until this is fixed -:

Do you know when release of 2.1 is planned?
I do not like manual installation from a snapshot and further manual upgrading and I afraid migration between to next snapshot version for sure there will be no migration scripts.

BTW I’ve upgraded to latest available build (I’m still waiting for the new build because it is not fixed) but like in 2.0 duplicated channels are visible for Flood Sensor.
I hope that in new buil it will be fixed and problem with triggering false alarm also will be solved.


I’m not sure-sorry.

This is expected as there has not been a new build for a few weeks. Hopefully this will be resolved in the next few days.

I’ve installed 2.1 from snapshoot, seems it works properly at least during 3 days I’ve not noticed this bug.