String type and Amazon Alexa

I’m in the throws of configuring a String item type cabale to integrate with Alexa. Such an item is responsible of controlling the alarm system and, so far, can have only two options: On and Off.
After several attemps, I set the item as follows:

String iAlarm_activation “Alarm_activation” [“Switchable”] {*channel=“openwebnet:bus_aux:mybridge:Alarm_activation:aux”,alexa=“PowerState” [actionMappings=“On=ON,Off=OFF”]}

Alexa won’t see it.

I am aware that for the burgrar alarm system a switch item type semantics is foreseen as per documentation; in my case however, due to the device kind, I am forced to use the String type.

Any idea?

For an alarm system, you should be using security attributes.

Group gAlarmSystem "Alarm System" {alexa="SecuritySystem"}
String iAlarm_activation "Alarm_activation (gAlarmSystem) {alexa="ArmState", channel="openwebnet:bus_aux:mybridge:Alarm_activation:aux"}

Alexa, arm alarm system
Alexa, disarm alarm system

What are the states your String type have related to your burglar alarm?

ON and OFF,
This week i’ll test the solution you suggest and let you know!
Thanks in advance for your help!

If you can’t use a Switch, then you could use a proxy item that you will use for the Alexa integration and update it via rules when your burglar alarm item gets updated.

1 Like

I tried the solution you talked about but no way to solve the issue.
Btw, I believe your tip may be useful to solve it in the near future!
So long

If you provide more details on how you tried to implement the solution, that would help identify why you couldn’t get it to work.

After numerous attempts I finally found a partial solution to the issue. I set the item as:
The only inconvenience is that vocal commands are not available (I tried the appropriate voice settings but no way so I left the Mode settings only) i.e. solely touch command are accessible via the Alexa App. This is not a problem given that controlling alarm via voice could be dangerous!
Thanks Again