Struggling to get jython scripting installed

So, I’ve followed the guides,

There seems to be some conflicting advice where to install the jython jar file.
I’ve enabled the Rule Engine in the paperwhile UI.
Is there someone on here who has tried to enable this recently, who can share their experience?
I’m seeing a .py test script I created being picked up by the ScriptFileWatcher,
2019-11-15 14:41:03.628 [INFO ] [rt.internal.loader.ScriptFileWatcher] - Loading script ‘’
but I’m not seeing the script engine activated as per the install guide.

btw, I just also tried a clean install just in case I missed something during the install.

Advice very welcome.


I followed the installation guide here.

Yep, did it the other day and followed the steps exactly.
Went smoothy. I am almost finished migrating my rules

OK great, let me tackle again. I’ll post an update how I get on.


The official docs are due for an update, but first I want to wrap up a Jython addon to massively simplify the install. Unless you are a masochist, you’ll appreciate the helper libraries and their documentation. I plan to move the generic portion of those docs into the official docs.

Let us know if you run into any snags!


Similar story here.

One rules file to migrate when I can make some time for the rewrite.

Rules DSL is a powerful language, but to be honest, Jython rules are much snappier than with rules DSL.

OK, following that guide made a lot of sense. I have it working. Funny, as I was almost there, but that guide is concise, and works.
Thank you.

I’m sure I’ll have a load of questions, but this is a really good start.


1 Like