Stuck in influx-install on raspberry Pi

  • Platform information:
    • Hardware: Raspberry Pi 2B
    • OS: Debian/openhasbian
    • Java Runtime Environment: I don’t know
    • openHAB version: openHAB 2.2.0-1
  • Issue:
    I tried to follow the tutorial; InfluxDB+Grafana last summer but got stuck somewhere. I didn’t have much time until now and I just tried again (first sudo apt-get remove --purge influxdb and same for grafana).
    But I think some things meanwhile changed. I looked through the tutorial-thread, but it’s very long, often off-topic, and most of it quiet frankly, is over my head. I also get lost sometimes because the thread links to other threads and sites for the raspberryPi and it is hard for me to find the right spot from where to go back up the tree of threads. Sorry if I ask a clumsy thing (again). Anyway, I think I did what is in the thread, but when I open influx console to make the database and add users, I get this:

[I] 2018-01-07T15:43:02Z InfluxDB starting, version 1.4.2, branch 1.4, commit 6d2685d1738277a1c2672fc58df7994627769be6
[I] 2018-01-07T15:43:02Z Go version go1.9.2, GOMAXPROCS set to 4
[I] 2018-01-07T15:43:02Z Using configuration at: /etc/influxdb/influxdb.conf
run: open server: listen: listen tcp bind: address already in use

And then nothing happens. What did I do wrong?

stop influxd service and check which linux process is using tcp port 8088

netstat -plnt |grep 8088

I found nothing running, restarted and now I see that I should start the console typing
’influx’ and not ‘influxd’. That must be my error. So sorry to bother you with this! But thanx for helping!