Super pom error message

Tags: #<Tag:0x00007f6162201690> #<Tag:0x00007f6162201528>

I tried to run an addon on my computer but encountered this error, which said

Non-resolvable parent POM org.openhab:openhab-super-pom:[1.0, 2.0) for org.openhab.addons:org.openhab.addons.reactor:2.5.9-SNAPSHOT: No versions matched the requested parent version range ‘[1.0, 2.0)’ and ‘parent.relativePath’ points at wrong local POM

I checked .m2 folder and the openhab super pom was downloaded with no problem. Does anyone know how to get rid of this error?

Welcome to the openHAB forum :raised_hand_with_fingers_splayed::raised_hand_with_fingers_splayed::raised_hand_with_fingers_splayed:

What are you trying to do, just running an openHAB instance with an addon or running a openHAB instance in Eclipse in order to change the code of the add-on?

Are you running eclipse 2020-06? Because I’ve seen this error with that eclipse version. I don’t know what causes it. I didn’t see it with older versions of eclipse.

Hi Juegen, I am trying to run an instance in Eclipse to do some modifications on certain addons to make them work for my case.

Yes I did use that version~ did you manage to solve it?

I installed version 2020-03.

Alright I’ll try that. Thanks :slight_smile: