SVG icons in the android app

What specifications are needed for the SVG icons?
Some icons are not showing in the android app (vector is ON).
Some are very blur and others work fine.
in the basic GUI all icons works fine.

1 Like

Maybe this is related to an existing bug

1 Like

The scaling issue is fixed in
The issue with the blured icon sounds like

After going to 2.3 I have the same issue.

I’m also on OH 2.3.0

Same Issue here.
I’ve just shortcuted the http://ServerIP:8080 on my Mi6 to my Android Desktop.
Works fine.
For everyone who wants a provisionally solution.

You need to update the app. It’s fixed in the latest beta version:

This seems to be totally unrelated. What was your issue?

SVG’s are shown in the Webserver GUI, but not in the App.

Thanks, that fixed it!

Hilarious, fix one issue break another. Wont connect to remote OpenHab Cloud using BETA app.

Can you give us more details? Which openHAB App version and are you using myopenhab or a self hosted cloud instance?

OH2.3 release and OpenHab Cloud which is self hosted.

Can you open a thread? I don’t want to mix this with the svg issue.

1 Like

Still have the problem documented above with the SVG icons in the Android app. All works well on the webview of the Basic UI … My openhab version per Openhab Dashboard is: openHAB 2.3.0 Release Build

Any hints/updates on this issue?

EDIT: SOLVED — Ok, I found that I have installed the version from Google Play Store which is still v 2.2.0 from May 2018. In one of the posts above I found that the scaling issue has been solved in the beta 2.2.5 … Got it from Github now and will test it!

Here is my solution for displaying SVG icons in the mobile app:
This works in both avaialable app verions from the Google play store:

  1. Stable version 2.2.0 from May 2018
  2. Beta version 2.3.7 from September 2018

In the settings there is a option to set the Symbol-Format which is either

  • Pixelgrafik (in English probably: Pixel Graphics)
  • Vektorgrafik (in English probably: Vector Graphics)

The Default is Pixelgrafik

With this setting the SVG icons are not shown. But setting the format to Vektorgrafik displays the icons.
So this might probably be the most likely reason why customized/indvidual SVG icons are not shown. I can not tell whether the scaling bug mentioned above has an impact in may case as my icons work in the stable version as well which does not include the fix for the bug.
But at least this is a first good try :slight_smile:

Hi Justus,
I have the same problem as you, my personal SVG icons are shown up in the Webserver GUI, but not in the App. I try to apply your solution, changing the settings, but I was unable to find this option. My App version is 2.5.0 from nov. 2018, and the Icon library is Android-Iconics. Could you tell me where is the Symbol-Format option? Thanks

Hi Javier,

this option is available in the openHAB beta app which is version 2.5.6 at the moment. It is also available in the Google Play Store. It is no problem to have both apps installed in parallel. Try the beta app and check if this solves your problem using the “symbol format” option in “Settings”.

I Just saw that the option is available in both apps standard and beta. I have also the version 2.5.0 from 24th November 2018 and the “Symbol Format” is right below the Design option. I will upload a screenshot … unfortunately it is in german. I hope you can understand it anyway:

The next screenshot shows the choice between “Pixel Graphics” or “Vector Graphics” … I don’t know how the developers translated that to either Spanish or English.

I hope this helps.

1 Like

Uploading screenshots in my previous reply to show the options in the apps!!!

Thank you very much Justus. Now I am able to see the icons, but they are shown smaller than it shows up on the Web page. Do you know what are the right dimensions for a .svg icon can show up correctly in both GUIs? By the way, these options appear rand

omly in the APP, now I notice it.

This preference is hidden if your server doesn’t support svg icons, i.e. openHAB server version 1. (
Which version of the app and server do you use and have you configured different servers in local and remote connection?

Can you post a screenshot?

Hi Mueller,
I recently updated to Openhab 2.4.0, and in both cases (local and remote) is the same server. The App version is 2.5.0 from nov. 2018. The weird thing is that now I see and I can choose the kind of graphics I want as I told Justus. On the other hand, I post the screenshots to the same view from the Web GUI and from the mobile App which shows up the differences between how they display the personal icons I made.