Switching to SSD


Like @sihui mentioned

And follow the link!

It appears from a lot of other forum discussions that the 3 B+ has some different firmware in it and was known to have issues with boots from external devices (no SD card). Some suggestions that the latest rasberrian stretch may have fixed it.

@Dave_G1 I don’t remember reading about issues with the 3 B+ but that’s been a few months ago.:thinking: When I first got my 3 B+ I put Raspbian on an SD card and booted up to verify it worked, it was a few more months before I moved my OH over and started using the 3B+. I used the instructions posted on the link above and everything worked the first time and I haven’t ran into any issue since. Maybe I just got lucky?

Not sure if this make a difference or not but I didn’t format or partition the SSD before loading the image. I just let Etcher do it’s thing and openhaban install took care of the rest.

Thanks both,

I followed the link and read the article.

I think I’m misunderstanding as the article reads as a fresh install onto the USB boot device.

I have a working system on an SD card which I would like to copy to the SSD.

I’ve made the changes to config.txt as per instructions, I then copied the image from the SD card and copying to the SSD using etcher, it didn’t boot without the SD card.

I could get it to boot from the SD card and use the SSD card for the root partition, but am unable to find any instructions or guidance to copy an image rather than a fresh install.


@james_2_roberts did you install OH (originally on SD card) via openhabian image?

No, I used apt-get to install OH.


Models prior to the 3 B+ required some bios flag to be set to enable boot from USB but apparently the 3 B+ has this enabled already. I used etcher to burn the github fresh image into the SSD via my laptop and it did boot and complete the install but a controlled shutdown would just hang and cold boots were less that 50/50 success rate.

I wonder if the same would be true of you used Etcher to flash the openhabian img.xz on your SSD. I know/think you prefer to install yourself, but if the image works, then you have something to compare against.

Here’s the link if you decide to give it a go.https://github.com/openhab/openhabian/releases/tag/v1.4.1

It was the openhabian image that I was having problems with initially and I was going to try the plain Stretch image today but it sounds like you have already done that.

I don’t mind too much if the sd-card is just used for the boot process and the rest of the operation runs from the ssd. Did you have some instructions on how to do that ?




This thread seems to describe the problem with the 3 B+ and maybe a solution - I’m not that savvy to understand it all.


Spent all afternoon with plain stretch and ssd drive - with and without external power but it just won’t reliably reboot. It will boot from cold and run ok - but a reboot is a non starter.

Finally settled on a micro usb flash drive of 128gb. Did a clean install of HO and it reliably boots and reboots without any SD-Card which will have to do for now.

Lots of posts on forums about the 3 B+ but nothing conclusive as to a stable solution. Maybe a plain 3 B would have been easier.


A plain upgraded rasberian stretch works on my ssd ok. I can shutdown and reboot cleanly now. I can’t shutdown from a newly created OH flashed drive. This is the same SSD that works with plain rasberrian lite.

There is s BCM number in the dump which might indicate what the problem is. The pi is connected to a physical network cable.

I tried a reboot sometime later and this appeared to display some kind of dump on screen for a fraction of a second and then all I got was a flashing cursor on the top right hand of the screen. I left it sitting there for about ten minutes to see if something would time out until I noticed that a small image of a thermometer appeared on the top right of the screen and the pi had become very warm. At this point I powered it off.

I don’t know much about Linux I have to admit but I assume there is a script or scripts which run when the system is shutting down. Is it possible that something in the script could be causing the problem but only when the system has not booted from the sd-card.

Would it be possible for me to boot from the SSD and type those shutdown commands one at a time to try and determine what is happening.

When reboot from the sd-card I see at least one screen full of log entries on screen before it comes back. If I repeat the process when booting from the SSD I see something like the previous screen dump for just a fraction of a second before the screen is cleared and it just hangs with the the cursor in the top left. If I leave it that way without pulling the power cable it starts to overheat so something is stuck in a loop.


Everything seems to run just fine on a Pi 3 with an sdcard. I don’t even have a cooling fan! Once it’s setup just fine, I take an image of the sdcard to another sdcard using a utility called rpi_clone. Then switch to this second sdcard to make sure all is well. From time to time depending on changes in the config files under /etc/openhab I backup these to my PC. I also keep a second Pi just in case. I thought about external storage but a local sdcard is cheap, self powered and discreet.


Are you cloning to a mounted share or to a local USB memory stick or USB SD?

As already mentioned some posts up, consider using Amanda. Can be used to backup and restore (thus also to clone) any raw device such as an SD card or SSD, and it will help you with automated long term storage of both, SD cards and files.

In my case a locally mounted sdcard thru USB.

No one best solution clearly just test the backup.

Use rpi-clone https://github.com/billw2/rpi-clone with

sudo rpi-clone -f sda

to copy everything from SD to SSD. Then identify new partuuid with

sudo blkid

Replace partuiid

sudo nano /boot/cmdline.txt partuuid

with new id from sda2. Reboot