Synology 214Play Installation Problem

Hello folks.
I am trying to get OpenHAB running on my Synology 214Play to switch home lighting of JB Media Light Manager Pro with Wifi Bridge.

These steps are done:

  • Installing the Java Manager via Packet Canter
  • Installing Java 7
  • installing (unzipped and manually installed via Packet Manager
  • creating the directory entries
    /public/OpenHAB/configurations and
  • gave user openhab rights for the public folder

The Java Manager and the OpenHAB packets are indicated as running.
I have no configuration files in the configurations folder.

Then I copied a openhab.cfg into the configurations folder and restarted the package.
In the Protocol I can read:
…Main openHAB configuration flle configurations/openhab.cfg does not exist
… Runtime has been started
…Service discovery initialization completed
…started REST API at /rest
… started Classic UI at /classicui/

The Package is indicated as “running”.
Starting the webinterface gives an error (Sitemap default could not be found).

So I am not sure if my directory “configurations” is recognized and have the feeling that I missed one or more essential steps.
The total absence of any configuration files might be the clue.

Do I need to install the distribution runtime ?

Thanks for a short push into the right direction!

Yes. is just the synology addon.

I don’t know Synology so can’t tell you how to do that though.

Ok thanks. I manually unzipped the runtime files into the folders.
Now I got many more lines in the Protocols.
Due to obvious errors in my configuration files it is still not running, but I am a bit closer.

Could anyone help me with the config files to just get the demo and interface running?

After about a week of reading, testing and configuring, I found out that we are not talking about a “steep learning curve” but the total absence of beginner friendly documentation.

Meanwhile I found out how the configuration files interact, but without any changes, my demo configuration stopped working.

The project seems to be a great sandbox for those who managed to suffer long enough to understand all cross linkings.

Today I tried to get Habmin running on my DS214Play and as there seems to be no documented way, I decided that I suffered enough and will stick with my 3 purchased incompatible systems that need to be handled by 3 different apps, plus one for the Security cameras.

PLEASE add real Help for beginners in the Beginner and Hardware threads.
Remember the days when you tried to figure it out and how long it took.
Else most new users might just drop it, like I am doing now.

Thanks for the nice platform,
Thanks for an interesting week.


I agree that better documentation is needed for beginners. We are stuck in an inbetween period right now though as OH 2 is coming out too soon to spend time writing something for OH1 but OH2 is not yet ready for production (though with the release of the Beta last week perhaps we have crossed that threshold).

But this forum is not the proper location for this information. It should be documented on in the getting started pages and on the wiki along with the demo for examples.

Also, OH2 has made lots and lots of enhancements whose intent is to make it easier for new users to become successful with OH sooner.

Some days ago I found this article:
Even if you dont speak german, you can see that a lot of energy was invested to explain how well the system performs.
The configuration files are explained, so I tried to adopt that system.
But all of a sudden the files are just there and huge.

My suggestion is, that someone posts a simple build like the demo, but documented with just a few sentences to ensure it will run.

That way the beginner will understand the installation with ease and can start implementing his real devices in a trial and error manner to get results within a short time.

It wil cost someone about an hour but save all upcoming beginners days if not weeks.

Just my “50 cent”

Hi MBuster

I want to have OpenHAB on my Synology
DS1513+ (INTEL Atom D2700) with «DSM 5.2-5644 Update 2».

Downloading and installing «KBOpenHAB-1.8.0-syno-noarch-0.001.ipk» was hasslefree.

Creating «gemeinsamer Ordner» «OpenHAB» and granting R/W permission for the User «OpenHAB» via Synology DSM also no problem. Adding «configurations» and «addons» via file explorer no problem.

Duplicating «@appstore/OpenHAB/configurations/openhab_default.cfg» to «gemeinsamer Ordner» «OpenHAB//configurations/openhab.cfg» no problem.

«Stopp» then «Ausführen» of the OpenHAB package showed a running package on the Synology DSM.

Opening webbrowser «http://(server):8081//classicui/» returns
.//. Problem accessing /
Reason: Sitemap ‘default’ could not be found

Opening webbrowser «http://(server):8081/classicui/» returns
.//. Problem accessing
/classicui/ Reason: ProxyServlet: /classicui/

Do you have any suggestions at this stage? I’m desperate…

Thank you for your support …


try the following:

  1. create /public/OpenHAB/configurations and /volume1/OpenHAB/addons
  2. install the spk you mentioned
  3. install the OpenHAB demo spk from the communities (this will help fix some permission issues and install 1.5 config and addons) if you dont have any skip this… or you can do manually if you know how to do it
  4. replace config and addons with the version you want (e.g 1.8)
  5. OpenHAB demo can be removed.
  6. vi /var/packages/OpenHAB/ and change /Timezone/tzname to tzlist (tzname not used in DSM5.2) it will fix the timezone…only if you have any problem on your logs timestamps etc
    hope it helps.

@Urs: that is exactly the same result as I got, but inbetween the demo web interface did work for some minutes and after some more “configuring” it stopped working again, but I could not find out why it worked and why it stopped…

@Rodgarcia: The directories you mention are different from what I did.
Is that the reason for the errors?
I have:

My way was:

  1. creating directories
  2. installing OpenHAB service on synology (1.8.8)
  3. installing OpenHAB Demo (1.8.8)
  4. Restarting the service (was started automatically on install)
  5. opening webinterface with an error as result

My Synology is changed to the port 5000 instead of 8080.
The short time the interface worked was when I tried to configure the port manually and restarted service.
But as I said, it worked for short and never again.

Thanks for your inputs.


I could be wrong but if you are using the spk from the correct folder is /public/OpenHAB/. Mine is and its working. And unless you changed the startstop port should be 8081.
The demo i mentioned is the one from the Synology community hofrichter I saw some people having problems with permission and this seem to solve the problem. you have to install it from the commnunity not copy the demo files to the public folder.

Yes, that is the file I edited to change to my port.
And thereafter it worked for a short time.

So maybe I overwrote that file by some more installing. I will check when I am home on tuesday.


Hi rodgarcia1

Thank you for your support.
I followed your receip … 1./2./3. OK --> The demo 1.5 worked. Yeah! Success!
Now I’m struggling with step 4.
Here the details of my unsuccessful tasks in step 4.

First try:
Within the DMS I created a «Gemeinsamer Ordner» named «OpenHAP» and granted access rights (R/W) for the user «openhab».
I copied with WinSCP the directories «volume1/@appstore/OpenHAB/configurations» and «volume1/@appstore/OpenHAB/addons» to my local Harddisk and then to the folder «volume1/OpenHAB/.».
I renamed the File «openhab_default.cfg» to «openhab.cfg»
Restarted the Service «OpenHAP» within the DMS.
Opened the Webbrowser http://{myserver}:8081/ --> HTTP ERROR 500 Sitemap ‘default’ could not be found

Second try:
Considering the DMS packet OpenHAB the directory for config and addons should be «volume1/public/OpenHAB/configurations» and «volume1/public/OpenHAB/addons»
(i.e. NOT «volume1/OpenHAB/» as in my first try)
Within the DMS I created a «Gemeinsamer Ordner» named «public» and granted access rights (R/W) for the user «openhab».
Then I created a subdirectory «OpenHAB».
I copied with WinSCPhe directories «volume1/@appstore/OpenHAB/configurations» and «volume1/@appstore/OpenHAB/addons» to my local Harddisk and then to the folder «volume1/public/OpenHAB/.»
I renamed the File «openhab_default.cfg» to «openhab.cfg»
Restarted the Service «OpenHAP» within the DMS.
Opened the Webbrowser http://{myserver}:8081/ --> HTTP ERROR 500 Sitemap ‘default’ could not be found

I’m sure there is something very little missing to have success with the installation.
Any suggestions?
Thanks to all for your support.


the idea of creating the public folders is that you don’t have to ssh in order to work with the configuration files. Create the folders before you install OH and then work with the public folders. When you do everything right your /volume1/@appstore/OpenHAB/addon will point to /volume1/public/OpenHAB/addon and so on.
4. just copy the configuration files you want to the public folders via dsm file station.
note do not delete the configuration_default.cfg leave it in the folder too


i have a similar problem. If my configurations folder is in /volume1/public/OpenHAB/ and there is a symbolic link from /volume1/@appstore/OpenHab/configurations to /volume1/public/OpenHAB/configurations, Openhab says that it cannot find the openhab.cfg file. But if i move the folder in /volume1/@appstore/OpenHab everything went fine. I have checked all permissions and they are right. Is there any Problem in OpenHAB with symbolic links?


Hi rodgarcia1

After several attempts it worked with your proposed procedure. It works with Openhab 1.8.1 & DSM 6.0-7321 Update 2). Thank you so much!

Reflecting the attempts I made…

  • creating a «Gemeinsamer Ordner» named «public» and granted access rights (R/W) for at least the user «openhab» before doing anything else!
  • installing a OpenHAB Demo is likelihood a must (whatever the demo modifies).
  • then modifiying the Demo…

Faster acting than the DSM may generate negative effects (It is just a feeling. I do not have evidence.).

KR Urs

dodo, rodgarcia1

I have a working environment in OpenHAB in Windows10 that I wanted to transfer to Synology
I followed the instructions in
post1: Synology 214Play Installation Problem, and
post2: Synology 214Play Installation Problem
I am able to start / stop OpenHAB from Synology package service, but I’m getting the error message: Sitemap ‘default’ could not be found

I’m confused about the public directory names.
Post1 mentions directory /volume1/OpenHAB/addons, but post2 mentions directory /volume1/public/OpenHAB/addon

Can you please clarify

  • the addon path should be /volume1/public/OpenHAB/addon or /public/OpenHAB/addon (or addons)
  • Post2 mentions "When you do everything right your /volume1/@appstore/OpenHAB/addon will point to /volume1/public/OpenHAB/addon and so on"
    Do I have to create softlink to map the directories, or the installation takes care of this for me?


I no longer use OH on my Synology but if memory doesn’t fail it is addons. I can confirm my current OH2 install in the RP3 uses addons. You don’t need to create the symlinks just the public folders. The public folders need to be created before the the installation. If not, you have to reinstall after the folders are created or have your default.sitemap, rules etc in the /volume1/@appstore/OpenHAB. Check all folders have the correct permissions. The demo package use to help with this. More often than not the problems I had using OH in the Synology were because of incorrect permissions. I hope it helps.

OK, I was able to resolve the problem (initially I forgot to copy over the config files openhab.cfg, openhab_default.cfg)

Here is what i did:

  • installed the public directories before the installation, and copied over the configuration files
    – directories items, sitemaps
    – config files openhab.cfg, openhab_default.cfg
  • made the permissions as wide as possible
  • installed the openhab runtime package (1.8.3) - the Synology Package Center shows that it is in a running state.

After ~1min the page becomes responsive.
The log can be viewed in /var/packages/OpenHAB/target/logs/openhab.stdout (I’m not sure why, but when I click on the “View Logs” in Package Center, I get a “No Data” dialogue box)