Synology DiskStation

synology
Tags: #<Tag:0x00007f6ce43e1fb8>

(Darrell Frappier) #242

I suggest that the Synology install instructions page be updated regarding the Java prerequisite.

The current suggestion to use the PC-Loadletter Repo is problematic. That tool has not been updated since January so it will install an out-of-date version of Java missing Oracle security fixes. Even worse, it installs a version of Java that will not work on certain ARMv7 machines.

My suggestion is to document the Synology maintained Java 8 package available from the Package Center on the DiskStation. After the Java 8 package is installed, open it and select the Upgrade Java box. The package will guide the user to download and install the current Oracle Java SE package appropriate for the processor of the Synology unit.


Problem installing OpenHab 2.1 Release on DSM 6.1
(Christian Häussler) #243

A new release is available:
https://github.com/openhab/openhab-syno-spk/releases/download/2.1.0.008/openHAB-2.1.0.008-syno-noarch-0.001.spk
Try it, please.
I have no DSM 6.1 DiskStation, Sorry!


(Dan Nielsen) #244

I have the same (no folders, no package download during installation process and no openhab user). Have a DS1511 and DS1512+ same on both… :frowning: I use the orginal Java package “ejdk-8u121-linux-i586.tar” (no manual update). I have made “Volume1/public/openHAB/conf”, “Volume1/public/openHAB/addons”, “Volume1/public/openHAB2/conf”,“Volume1/public/openHAB2/addons”. Don’t know if the folder should be called openHAB og openHAB2?


(Christian Häussler) #245

I have created a new version:


(Neil) #246

thanks for 2.2 snapshot 7, Christian - it’s installed and is running well on my DS214play with DSM6.


(Dark Lite1) #247

It’s already been said before in the thread, but why is the package not available in the SynoCommunity repo? When checking this we can see that Home Assistant is just there, but OpenHAB is not. It would make life a lot easier then hunting down packages…


(Kurt S) #248

Hi,
first of all thanks a lot for this package and the effort you’ve spent on it! I love it :slight_smile:

I’ve installed it, migrated my /conf files and basically all worked fine instantly.
The only cumbersome issue I face, is that the logs stay empty completely, displaying “No Data” in the Packet Center.
I’ve given the Openhab2:Users read/write access to /volume1/@appstore/openHAB2/userdata/logs$ but this didn’t have any effect.

I’m running
DSM 6.1.3-15152 Update 6 (this issue was present in Update 4 & 5 before) on a DS716+II with 2.2.0-007-SNAPSHOT installed on it.

May I please ask your support what to do to get the logs filled?

thanks in advance,
Kurt


(Neil) #249

hi Kurt,

I’m running the same snapshot and the logging is working OK. (that’s with DSM 6.1.3-15152 Update 6 on a DS214play).

I’ve just noticed you say “Openhab2:Users”, but on my system it’s ‘openhab2:users’. Might that be it?


(Kurt S) #250

Hi,

Thanks for your swift reply, but it’s actually owned by openhab2:users

I still get an empty logfile
18


(Neil) #251

does the log files exist at
/volume1/@appstore/openHAB2/userdata/logs/openhab.log …?

That’s where the package centre will be reading the log file from.


(Kurt S) #252

Hi,

the file itself is there, but it’s not being populated, having 0bytes in size.
that’s why I initially thought it’s just lacking r/w of the openhab2 user - but this seems not to be the root cause.

:-/

Kurt


(Neil) #253

that’s reached the limit of my knowledge then, sorry.

The only idea I can suggest is stopping OH, deleting the log file and then restarting OH.


(peter) #254

Tried Installation on Diskstation 713+
Several SPK 2.1.0-008 and the 2.2.0 -007
Using newest dsm 6.1.3…

Before manual istallation it says: (translated from german)
Port undefined, which was configured for this packag will be used either by other service or is reserved…

I assume that there is a port configured with name "undefined"
Do I have to define the port anywhere? anyhow?
thx
Peter


(Kurt S) #255

Hi Peter,

This happens if one of your applications uses the 8080 port, or if you re-installed the pack at a certain time.

Under /usr/local/etc/services.d there are files containing package related data. They’re called “something.sc”. One of them will contain a "dst.ports=“8080/tcp”.
Try changing the .sc file content to another port, or respectively delete the old openhab entry.

Kurt


(peter) #256

thx , that helped.
I also had to change the access rights for my z-wave stick /dev/ttyACM0
Or is there any rights configuration I missed?


(wolf_from_the_north) #257

can anyone tell me how to update from 2.1 to 2.2 ?
the update script from openhab is only good for unzip commands wich dsm 6 does no longer have.
kindest regards


(Darrell Frappier) #258

DSM 6 replaced unzip with 7z


(wolf_from_the_north) #259

Correct but the script only uses unzip, is there a possibility that some
adjust this to use more then only unzip ?


(Darrell Frappier) #260

I suggest that you have at least 2 ways to fix your issue.

Change the script to use 7z rather than unzip.

Add a symbolic link from 7z to unzip on the Synology. N.B. I have not checked the unzip flags used in the script to verify if they work with 7z.


(wolf_from_the_north) #261

Clever solution but this will not work i’m afraid, the commands from zip are different as i tried to match them.
Also i am no linux supper scripter.
A symlinkni never tried and i also have no test machine.
This issue i mention is because till now i never succeeded in upgrading and this is frustrating me allot.

Kindest regards