Synology DS213+ and OpenHab not running

First I installed JAVA SE Embedded 8 (Version 1.8.0_6-0034)
Then I installed manually 2.0.0-beta2-DSM6-RC from

Went to SSH and created both /volume1/public/OpenHAB2/addons and /volume1/public/OpenHAB2/conf ( I tried even with /volume1/public/OpenHAB2/configurations) .
gave permissions to these folders to openhab:users

Then from Package Center => Action => Run

But always the Status remains Stopped

I don’t know what I am not doing as expected and what I have to do…

Any advice?

I had the same issue as you. I think it has to do with the DSM 6 on the Synology not having the proper unarchiver (zip vs 7zip). I am running 1.8.2 since I couldn’t get it running.

Also I found that you need to create the openhab user and give the public folder permissions prior to the install or it wouldn’t use the pubic configuration folder. (and when you uninstall to reinstall, you have to create and assign permissions again since the uninstaller deletes the openhab user). Though I could have been doing something wrong though.

1 Like

Thanks a lot for the hints!
It worked - at least OpenHab now is running ( although I am not able still to connect to demo site).

Here is what I did:

  1. Uninstalled OpenHab package
  2. Created user openhab
  3. Gave permissions (read/write) on public folder
  4. Installed it manually (2.0.0-beta2-DSM6-RC from
  5. and it is running

Great! What URL are you using for the demo site? Something like http://x.x.x.x:8081/ ??

Yes : http://mydsip:8082/
I installed(copied) also the demo files to public\OpenHAB\addons and public\OpenHAB\configuration
made ln inside /var/packages/OpenHAB/target
configurations ( last two one are just in case it is looking for any of them)
When I start the server - I can see the web page and port in the package manager
When I open that page "This site can’t be reached"
No idea why…

if you started from openhab 1.8 or before it wil have made a complete install-site in @appstore/openhab, try migrating one to the other . it worked for me. its running from te original @appstore

No the install was clear.
And I made sure that I changed the original path ( addons and conf) and put link to the public ones

Not sure where to look else…

Did you check if all your scripts are populated ? especially sitemap and configuration.

I found “demo.sitemap” in the configuration folder coming from demo files- seems ok.
But no “configuration” file anywhere…


that one

I checked all folders and I don’t have such a file anywhere.
I went to the github downloaded the default one, put that in configurations folder, but it is not helping.

it needs to be renamed as openhab.cfg without the ‘default’

did that already - no change

there 's only one other thing i can think off. Do you operate everything from withing dsm ? i installed en startup openhab from a ssh terminal (mobaxterm) . there is a debug mode as well .