Synology Surveillance Station Binding

Hi @adm105

I tried to use modified version of the Clickable Camera widget, but not getting it work.

Please share your widget when you have it ready

I have other problems to solve first. I can therefore only turn to my own widget much later.
What’s not working about the modified version of the clickable camera widget? Starting there is a good idea.

Well about nothing works at the moment.
I slightly played with modifying the widget to use the state of item instead of setting the link address for getting snapshots and live videos.
However I get the snapshot only once on initialization, but doesn’t refresh afterwards.

Ideally I would like to get a snapshot on a motion detection from a physical motion detectors (and not from the camera or Synology software processing), and also maybe get refresh of the snapshot manually.

BTW I also do not get any video on the link address that I retreive from the item states. Not sure why, are there any synology settings?

Hi Darko,

I also have this problem on a regular basis. I have the addon “org.openhab.binding.synologysurveillancestation-3.3.0-SNAPSHOT.jar” installed. It is probably also crucial how the camera is recorded in the Synology Station. My camera was found via the model name, but I also tested the possibility using Onvif. However, the parameters that are then passed to OpenHAB 3 are identical. That reminds me, what camera are you actually using?
In addition, I would have to adjust the item names in the widget. Then I could watch the live stream in OH3 for a period of time and then the next day the screen went black again. I think an update rule needs to be built in. So far I can only look at the current status of the various settings via OH3. No changes are possible at this point, apart from stopping the stream or recording.
Before I dealt with the Synology Addon, I also dealt with Motioneye in Docker superficially. The program wasn’t that bad for a long time and you could also access it from OpenHAB 3. As far as the settings via Openhab 3 are concerned, I would have to test again first.
In the meantime, however, I think that a live stream and a snapshot for OH3 are completely sufficient and that the settings are made via the main program.

I have several Dahua bullet cameras about 6 years old and they are configured according to their model in the Synology Surveillance Station.

I never managed to get video with this binding although I didn’t try a lot.

Hello Darko,

Just to give you a better understanding: You can see a stream in Synology Surveillance Station but not in OpenHAB 3? Or do you not see a stream in both?
Are your cameras Onvif ready?
Take a look at this link, it might be of some help.

Please feel free to contact us again afterwards.

Not sure but I think yes, since it supports
H.264 protocol

also yes

My cameras are not in the list, the actual model is IPC-HFW1320S

I checked, the camera you mentioned supports the Onvif protocol. I also wrote above that I also have problems with the Surveillance Station widget. Have you tried it with the ipcamera binding? But then you have to uninstall the binding “org.openhab.binding.synologysurveillancestation-3.3.0-SNAPSHOT.jar”.

Any reason why they can not both be installed at the same time? Some cameras can talk to multiple devices at the same time, whilst others can only speak to one binding or NVR device without issues. Worse case you should only need to press the PAUSE button on the thing to stop the other binding from talking to the device whilst you try another binding in case the camera itself can not talk to multiple bindings.

No, I don’t know why. But I read that somewhere here and now I’m just trying to help Darko. You’re the expert here and you probably know it better than I do. Then it’s okay with me if you support Darko with his problem.

a) I’m not tech support, but I’m happy to post when help and clarification is needed if someone opens a new dedicated thread.
b) Huge thanks to you helping out another user, don’t take my comments as aimed at you. I’m busy and will make short posts to make this quick.
b) High jacking a thread should not happen. If someone wants help, they should open their own new thread and no posting should happen on this one.

Don’t expect others to spend time helping, if you don’t try first. Recommend you read the documentation for the IP Camera binding as a first step as your cameras should work just fine. As for the binding in that this thread is about I have no experience with it.

Hi guys,

Thanks for the support but it was never the intention to hijack any post. It all started with a question if @adm105 managed to make the widget for the binding, since I tried to do so and failed. However from the discussions it seems we do have common problems, although bit bigger on my side.

And as probably everyone on the forum, free time is always an issue. I have this binding installed for almost 2 years now but since my logic far was to configure the OH system as automatic as possible I never had time or put bigger effort so far to take the benefits so far. Same story witt the IP camera binding, it is installed for about the same duration as the Synology binding but I didn’t configure any cameras sunce I planned to try the Synology binding first, because as I understand the CPU load could increase when using some functionality. I breafly tried it but failed to get the video, which is probably related to some firewall rules I have related to the cameras.

Now back to the problems I face with the widget, when I post the link of the snapshot in Google Chrome, I get the last snapshot, however in OH UI and Android App theere is no refresh. So when the app or webpage is first started I get the snapshot, but refreshing it fails.

As mentioned before I am not in hurry so I will have a look in the issue when the weather gets worse :slight_smile:

System :
Raspi 4 4GB Openhab version: 3.4.0 buildString: “Build #2975
Synology 218+ DSM 7.1-42661 Update 2
Camera Foscam R2 as ONVIF

I installed the Bridge to the surveillance station on the syn 218+ and get the fault message „407“ and “Thread HomeMode”.
Ip is port 5000

Is there any setting wrong?
best regards

2022-06-28 09:15:55.721 [ERROR] [ternal.webapi.request.SynoApiRequest] - RESPONSE: {"error":{"code":407},"success":false}
2022-06-28 09:15:55.723 [ERROR] [tation.internal.thread.SynoApiThread] - DeviceId: Bridge; Thread: HomeMode; Attempt to reconnect failed

According to the API, 407 means “max.tries reached if autoblocking is set to true”. Please check your settings/credentials or create a dedicated user for this purpose. If it’s still not working, I can look into it later…
BR Pav

1 Like

That‘s it. Thanks a lot

Because snapshot, Homemode and camera activation is working pretty well, I try to move or zoom the camera via Synology station. Is there anything else I have to arrange besides storing the command „LEFT“ in the move item, maybe in the NAS? The camera is not moving anyway.

I assume you can move your camera from within Surveillance Station already.
For moving your camera using this bundle, please link your Move channel and send one of following commands to this channel: UP, DOWN, LEFT, RIGHT, HOME (with a rule or a sitemap button).

System :
Raspi 4 4GB Openhab version: 3.4.0 buildString: “Build #2975
Synology 218+ DSM 7.1-42661 Update 2
Camera Foscam R2 as ONVIF

I can move the camera from within the Surv. Station in all directions (left,right,up and down), but it does not react to any command via the “move” ITEM.


I set three preset positions (Door,Window,Shelf) and a Control tour (Tour-1) with 60 sec dwelltime in every position(three Positions) in the Surveillance Station.
The camera moves to all Preset Positions via command


The camera traces “Tour-1” and also stopps at every point with command


there is one cycle of the tour and you can’t stop the cycle with any command (right ??).
When the tour is finished just restart it with the same command without any command change.

Everything fine so far except the move.

Oh that’s bad… I don’t have a ptz camera and can’t test it right away.
I don’t see any obvious errors in the code. Please try
START_UP / STOP_UP instead, this could be the right method for your case.

This part of code is one of the oldest implementing the earliest API available. Then it wasn’t possible to stop patrols. With new API version it should be possible but it would require refactoring I can’t test. But if you need this function and/or you’re willing to contribute to this project, I can look into it sometime :wink:

„START_LEFT“ and „STOP_LEFT“ works perfectly. Thanks a lot.
I am fine so far, but if I can support you with my ptz camera, please tell me how I can go ahead. I don‘t know how to join the project.

1 Like