System info binding: channel load COMMUNICATION_ERROR

openHAB version 4.1.2 on a proxmox system

I have a problem with the System Info Binding and especially with the channel Cpu#load

As soon as I link an item here, the thing reports an COMMUNICATION_ERROR error.

All other channels work without problems, anyone have any ideas?

I have tried all possible settings for the item

  • unit one
  • unit %
  • state decription pattern %d %%
  • and without
    but I keep getting the error.

The log says the following

2024-05-08 10:06:54.815 [DEBUG] [o.internal.handler.SysteminfoHandler] - High prioriy tasks will not be run anymore!
2024-05-08 10:06:54.816 [DEBUG] [o.internal.handler.SysteminfoHandler] - Medium prioriy tasks will not be run anymore!
2024-05-08 10:06:56.580 [DEBUG] [eminfo.internal.model.OSHISysteminfo] - OSHISysteminfo service starts initializing
2024-05-08 10:06:56.606 [DEBUG] [o.internal.handler.SysteminfoHandler] - Systeminfo implementation is instantiated!
2024-05-08 10:06:56.606 [DEBUG] [o.internal.handler.SysteminfoHandler] - Start reading Thing configuration.
2024-05-08 10:06:56.606 [DEBUG] [o.internal.handler.SysteminfoHandler] - Refresh time for medium priority channels set to 60 s
2024-05-08 10:06:56.606 [DEBUG] [o.internal.handler.SysteminfoHandler] - Refresh time for high priority channels set to 1 s
2024-05-08 10:06:56.607 [DEBUG] [o.internal.handler.SysteminfoHandler] - Properties updated!
2024-05-08 10:06:56.608 [DEBUG] [o.internal.handler.SysteminfoHandler] - Schedule high priority tasks at fixed rate 1 s
2024-05-08 10:06:56.608 [DEBUG] [o.internal.handler.SysteminfoHandler] - Schedule medium priority tasks at fixed rate 60 s
2024-05-08 10:06:56.608 [DEBUG] [o.internal.handler.SysteminfoHandler] - Schedule one time update for low priority tasks
2024-05-08 10:06:57.608 [WARN ] [o.internal.handler.SysteminfoHandler] - No information for channel battery#remainingTime with device index: 0
2024-05-08 10:06:57.608 [DEBUG] [o.internal.handler.SysteminfoHandler] - Channel with UID systeminfo:computer:openhab:process#path tracks process with PID: 0
2024-05-08 10:06:57.609 [WARN ] [o.internal.handler.SysteminfoHandler] - No information for channel battery#remainingCapacity with device index: 0
2024-05-08 10:06:57.688 [WARN ] [o.internal.handler.SysteminfoHandler] - No information for channel battery#name with device index: 0
2024-05-08 10:06:57.714 [DEBUG] [o.internal.handler.SysteminfoHandler] - Channel with UID systeminfo:computer:openhab:process#name tracks process with PID: 0
2024-05-08 10:06:57.789 [DEBUG] [o.internal.handler.SysteminfoHandler] - Channel with UID systeminfo:computer:openhab:process#used tracks process with PID: 0
2024-05-08 10:06:57.802 [DEBUG] [o.internal.handler.SysteminfoHandler] - Unexpected error occurred while getting system information!
java.lang.IllegalArgumentException: Value must be between 0 and 100
	at org.openhab.core.library.types.PercentType.validateValue( ~[?:?]
	at org.openhab.core.library.types.PercentType.<init>( ~[?:?]
	at org.openhab.binding.systeminfo.internal.model.OSHISysteminfo.getSystemCpuLoad( ~[?:?]
	at org.openhab.binding.systeminfo.internal.handler.SysteminfoHandler.getSystemCpuLoad( ~[?:?]
	at org.openhab.binding.systeminfo.internal.handler.SysteminfoHandler.lambda$0( ~[?:?]
	at org.openhab.core.cache.ExpiringCache.refreshValue( ~[?:?]
	at org.openhab.core.cache.ExpiringCache.getValue( ~[?:?]
	at org.openhab.binding.systeminfo.internal.handler.SysteminfoHandler.getInfoForChannel( ~[?:?]
	at org.openhab.binding.systeminfo.internal.handler.SysteminfoHandler.publishDataForChannel( ~[?:?]
	at org.openhab.binding.systeminfo.internal.handler.SysteminfoHandler.publishData( ~[?:?]
	at org.openhab.binding.systeminfo.internal.handler.SysteminfoHandler.lambda$2( ~[?:?]
	at java.util.concurrent.Executors$ [?:?]
	at java.util.concurrent.FutureTask.runAndReset( [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:?]
	at java.util.concurrent.ThreadPoolExecutor$ [?:?]
	at [?:?]

What type is the Item?

I have absolutely no idea, but now it works. I did a reboot but did not change the item

and the meta data are

State Description Pattern is %d %%

Knowing the types of your Items is pretty basic stuff which you should know and understand or, at a minimum know where to look.

From the screen shot the Item type is Number:Dimensionless.

The reason I asked is that the error indicated that the Item either was a Dimmer or it was expected to be a Dimmer.

@rlkoshak Sorry, that was a misunderstanding on my part. With the statement
I have absolutely no idea,
I meant that I don’t understand why the error disappeared.

The item type used was always of type Number:Dimensionless.

The item was automatically added with create a new item under at link to item.

One more question, where do you see in the log file that an item type dimmer is expected there.

A Dimmer Item carries a PercentType as it’s state. See Items | openHAB.

Before the adoption of units in OH and updates made in OH 4 to make their use more consistent, many bindings uses Dimmer Items to represent percentages instead of Number:Dimensionless.