Tabs not shown in Main-UI

Hi all,

since I reconfigured my main-ui with new widgets, I cant see the tabs (locations, equipment, properties) anymore and thus also cant access my device that are not on the overview tab.

I already tried changing appearance etc. but nothing works.
Am I missing something? Because on the desktop the tabs are shown as expected.

OS ?
Java version ?
openHAB version ?

Anything suspicious in the logs ?

Please provide more information?

Are you using firefox?
Press ctrl-r to reload the page.
Also try restarting openHab.

sry for the missing information:

OS: Android 13
OH version: 4.0.3-1
Java version: openJDK 17.0.7

nothing suspicious in the logs. It seems to be a display error. As I said all tabs are shown properly on desktop, its just the app…

edit: maybe I am in the wrong forum, but I thougth this is giving support for the app: So, no, I am not using firefox but chrome. And I just tried accessing the openhab page from chrome on mobile directly and it also doesnt show the tabs… So maybe its related to chrome after all…

edit2: just tried firefox, also doesnt work. Is there an option somewhere to hide the tabs on mobile that I might have accidentally activated?

No, it is the right community, I first had overseen your information about the tabs showing in the browser too.

Habe you by mistake configured your tabs to only be shown when logged in ?
Using a browser on your Android device, do they show up ?

thanks a lot for the hint!

You are right, when I log in on mobile I can see the tabs. So it seems to be an issue with not showing tabs when not logged in…

But I have configured the tabs to be shown for all users. Is there another option somewhere to also show them when not logged in that I have to activate?

Setup a token and put that token into the app to autologin.
Best way is to create the token in the browser on your smartphone to get the option to paste via clipboard

1 Like

using an api token doesnt change anything…

But I also tried using username and password in the settings and get a authentification error 401

Puh, something seems still to be wrong somewhere…

Did you already try landscape and portrait mode?

Yes, doesn’t work either.

I now changed the api settings in openhab and the error 401 is gone again.
But I still can’t see the tabs.

However, when I login in the app within the main ui in the sidebar (similar to what I do in the browser) I can see the tabs. But unfortunately they are gone again when the app is closed. So it’s not a permanent solution.

So it seems that the login via app/api doesn’t work. Is there anything else I can try?