Tahoma Binding compatible with OH2

Hi @hakan,

the merging to the master is a bit slow, but these two versions exist:

The latest V1 includes:

  • shared HTTP client (saving OH2 resources)
  • correct handling of gateway states
  • proper updating of thing states (less communication with the same result)
  • proper managing of executions (less communication with the same result)
  • improved detection of gateway type (Tahoma, Connexoon, …)
  • overall better performance

According to my opinion the V1 version is still more stable and the recommended one, since the V2 had caused weird issues to some users.
I plan to request merging of the V1 version to the master soon, but other commits (bringing support for new things) still wait for merging…

Feel free to test :slight_smile:

1 Like

Thank you, I guess I will stay with V1 for the time being. In two days, a big remodeling of my home will be done (switching 4 RTS motors to 9 iocontrol ones), so I want to get things working nicely first before experimenting with new APIs :grin:


I have now also bought the connexoon. But like some before me here, I also have the problem that I can’t register on https://www.tahomalink.com I get the error message Wrong username or password. I have already changed my password several times, but I just can’t log in.
Somehow Somfy seems to me to be very error-prone with its products, if I had known that, I would have left my fingers off it…

I would like to draw your attention to a mail I received from Somfy stating that I still use an old version of the API and that it will expire on Dec 3. Since I’m using OpenHab 2.4, I guess the binding version in this release still contains the old API. Is there any way to upgrade to the new API (within the stable OpenHAB 2.4? Someone opened a dedicated post for this: Somfy / Tahoma old API

I’ve noticed Somfy’s registrations are by locality. Where did you buy your box from vs. where are you living?
For reference I’m in Australia but bought my box in the UK and had to register it as a UK box with a UK address.

Thanks for the info, had no idea this is going to happen so soon.
So I’ve returned to the v2 version branch and I’ll be glad if we can test it…



I’m happy to help testing. Just let me know what you need to see and I’ll get it sorted/started this weekend.

Just test the reliability, please. It should be working, but API change is always a bit risky.
Thanks :slight_smile:

Hello, I have copied the new version to the directory Addons. After I restarted the system, the addon in the Paperui under Configuration / Bindings is no longer displayed and things show an error. Version V1 continues to work without any problems.

OH2.4? Please check log file. I needed to install dependency google gson 2.8.5 jar.

Hi, sorry - I haven’t emphasized that for OH 2.4 you need either

  1. upgrade to OH2.5 first
  2. to manually install a newer gson jar
  3. edit the MANIFEST.MF file in META-INF dir in the provided jar, so the newer gson is not required (the code works with the bundled gson in OH 2.4 as well)


Hi, Step 3 works for me!

Thanks, please create an issue, so I can add support for the Camera thing.

Regarding the warning - type id switch has been replaced by system.power, I guess you need to restart OH2 and if it does not work out, clear the caches…


I’ve updated to the latest Somfy Tahoma 2.5.0 binding snapshot. @Ondrej_Pecta I used your 3rd method to get the binding to work on OH2.4 Stable.

So far all good, all blinds (roller shutters x 9) have initialised and are online but will await until my rules kick in to check if everything is behaving as expected.

Hello Ondrej,
I installed also the newest tahoma binding after the update of the TahomaBox.
The binding works for my rollershutters, roofwindowblinds, roofwindow and enocean windowhandle.
I wanted to ask, if it is possible to see the status of the rollershutters (and others) via the binding? (when i use the switch next to the windows or the remote control)

thanks for your effort and your answers in advance



sure, this should be working.
The Bridge thing has configuration param Status timeout, which defines the timeout for syncing the status. It forces all the things to send the current status.

Try lowering the value and see if it works. If not or not sure, just PM me the debug log of the binding (enable the debug first)

O.k., answering a tiny bit late, but the V2 binding works perfectly on my production system since you posted. Even with the API update on 26.11.2019.

I have only 8 rollershutter motors though, no exotic hardware.

Hi guys,

whats about the Dez. 3th Server change, my Bridge is offline, how its about yours?



1 Like

Same for me, I can’t use it anymore… I’m still on 2.4, what is the full procedure to get this working ?

1 Like

I’m on OH2.5-M5 and it stopped working for me around half an hour ago as well. I can still control the screens using the app, but I can’t login to www.tahomelink.com (although I’m 100% certain the username/password are correct). Resetting the password (confirmed working in the app on my phone) didn’t make a difference. Anything I can do to help analysis?

As mentioned earlier in this thread, not being able to login to tahomalink.com seems to be the culprit, see log below:

20:23:27.617 [DEBUG] [rnal.handler.SomfyTahomaBridgeHandler] - Getting Tahoma Updates...
20:23:27.624 [DEBUG] [rnal.handler.SomfyTahomaBridgeHandler] - Doing relogin
20:23:32.634 [TRACE] [rnal.handler.SomfyTahomaBridgeHandler] - Login response: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xml:lang="fr" xmlns="http://www.w3.org/1999/xhtml">
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
        <title>Overkiz - Error</title>
        <h2>Bad request</h2>
<i>Tue Dec 03 20:23:32 CET 2019</i><br/>


20:23:32.642 [DEBUG] [rnal.handler.SomfyTahomaBridgeHandler] - Received invalid data
com.google.gson.JsonSyntaxException: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 1 path $