Tahoma Binding compatible with OH2

Tags: #<Tag:0x00007fc8f9c438c0>

Hi Ondrej,

Im trying to get your awsome binding to work for my setup, but the binding wont let me log in to the tahoma cloud (to many requests, skipping login).
I;ve tried my credentials via https://tahomalink.com/enduser-mobile-web/enduserAPI/doc and everything works. I can retrieve the shutters and their status just fine. Turning on debugging only reveals the forementioned errors. Is there anything else i can do to debug / find the problem i am facing?

Fixed the problem. For future reference:

  • Uninstalled Tahoma binding
  • Rebooted OH
  • Cleared OH Cache
  • Rebooted OH
    -(re)Installed Tahoma binding.

“To many request error” was no longer bugging me and the binding succesfully logged in to the Tahoma cloud.

Hi Ondrej,

I can’t connect the Tahoma-bridge. The displayed error is: Status: OFFLINE - COMMUNICATION_ERROR Cannot get login cookie. I also uninstall the 2.5.2 binding and tried the 2.5.6., same error. I uninstalled the binding, stopped OH2, cleared the cache and tmp-files, restarted OH2, installed the 2.5.6 binding -> same error. I think the error occurred after an update of the Tahoma-station. Do you know a solution for that kind of problem?
Thanks for your support.

1 Like

After an update of the Tahoma-station still the same problem.
Someone any idea?

1 Like

Hey,
how to Clear the Cache of OpenHAB2?

I have the same problem as you. “Too many requests”

1 Like

see also here: Clear the Cache

in short: connect to your openhabian via e.g. putty, then :
sudo openhab-cli stop
sudo openhab-cli clean-cache
sudo openhab-cli start

1 Like

Hi,
Same problem here with binding 2.5.6. Any advice appreciated :slight_smile:

hi,
I got following error during connection to the Somfy Connexoon Box:
Status: OFFLINE - COMMUNICATION_ERROR Authentication challenge
The app is still working but I cannot login by using the webinterface.
Daniel

Hi, I have the same problem since the last Tahoma update and I use the openHAB 2.5.7 release build. After I also got the error “Too many request error”, I now have the error “somfytahoma:bridge:xxxxxxx’ changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Cannot get login cookie”. Funnily enough, this error no longer appears when I log in to Tahomalink via webinterface of a normal browser (not the TaHoma app). After a while, however, the error reappears in OpenHAB. I don’t know well technically, but does this have to do with any login sessions that may be associated with my Internet IP address, as I only see the IP address as the only commonality between the webinterface and openHAB? I can’t explain it any other way.

Hi , i’ve got the same issue with 2.5.7 (unfortunately I missed to check immediately after update to confirm connection with the update)

Have you solved the reported problem in last 2 weeks?

I set up a fresh OH2 and it was there as I made a mistake. It can be resolved with clearing cache and reboot (several times)

After an update and several restarts it worked.

Hello, I had an issue today when updating to openhab 2.5.8-1

See here Items lost + error 500 after update to openHAB 2.5.8-1 (Release Build) ...backup not working :-(.

The guilty one was the link between the RSSI thing and item. Everytime I link the thing and item, All Paper UI items are not visible. Here is the error in openhab.log

2020-09-13 21:55:38.491 [ERROR] [ersey.server.ServerRuntime$Responder] - An I/O error has occurred while writing a response message entity to the container output stream.

Also, when I try to set a location for my Roller Shutter Things, via PaperUI, it’s not working.
I have Error 500 when saving the thing, and the location is not saved.

It’s working for the scenario (Somfy Action Group)

If you definde your things in text configs, ou cannot change t in PaperUI.
But you can set the location in things file as well

"your label" @ "your location" [config options]

Hi all,

I have had OH2 operational for a year or so now. I have just recently added a Somfy Connexoon box (in Australia) along with the Somfy Binding v2.5.9 however I am not able to authenticate with the following error displayed in the Paper UI when I enter my credentials for the iPhone app:

Status: OFFLINE - COMMUNICATION_ERROR Authentication challenge

I have everything operational with my Somfy Connexoon app on my iPhone. I am told by Somfy Australia that there is no online account to log in through the web so I am at a loss as to why I am getting this error. I do not have a Tahoma login but I’m not sure if I need one.

Sorry if this has been answered already however I couldnt find any answers when searching this thread.

Thank you
Anthony

Sounds like the same problem I’ve had not long ago. When I set logging to debug I got the error " skipping login due to to many requests" if this is the same for you, I got my problem resolved by:

  • Uninstalled Tahoma binding
  • Rebooted OH
  • Cleared OH Cache
  • Rebooted OH
    -(re)Installed Tahoma binding.

Hope this works for you.
Btw. If you have a conexxoon you don’t get a tahoma login. Your conexxoon however logs in at tahoma cloud. But you are not able to interact with it yourself via a browser. Only Tahoma users have this privilege.

Hi Marty,

Thank you very much for your response.

I tried the steps you outlined in your response but unfortunately it didnt work.

Just to confirm, it is the Somfy Tahoma Bridge Thing I install, not the Somfy Tahoma Gateway?

Does anyone have any other suggestions?

Regards
Anthony

I’m experiencing the same, also with a Connexoon.
This has worked fine since late 2019 but only started giving issues after the most recent Connexoon firmware update.
I also can’t seem to log into the TaHoma website with my account even after resetting password, I was sure the password was correct in the first place though.
Maybe some changes were made from Somfy’s side?

1 Like

I disabled the binding for a day and just enabled it again and now it can log in again without issues.
Not sure if this is coincidence or not but happy it works again :slight_smile: