TaHoma Binding does not work in OH 3.4.4 - Could not register events

Since some days my Tahoma binding has stopped working. As I have seen on GitHub I am not the only one: [somfytahoma] unable to register events after a week · Issue #14530 · openhab/openhab-addons · GitHub

Since there is no reaction so far I would like to check:

  • Who has the same error when using Tahoma binding? (“Could not register events”)
  • What can be done to analyze and solve the topic?

Thanks in advance!

Same happens to me. Tahoma Switch conecta throught wifi. Sounds strange, but the problem that I observe is that Tahoma Switch looses IP address from DHCP and can’t recoger from that state.

Do you have an idea how to solve it? I have restarted openHab and issue still occurs. In Devel-Mode the (local) IP is found an even a token is generated, but still error arises “Could not register events”)

Hi, unfortunately seems I encounter the same issue … shortly I could connect via cloud disabling dev mode. But then after a short while I get the same error message. Any hint would be appreciated :slight_smile:

Connected througout ethernet cable adapter and connection is stable last 2 weeks.

I suspect that Tahoma Switch looses IP from DHCP negotiation when WiFi connection is selected. Error from Somfy bridge in my opinion.

Hi Miercol, not sure I understand. I have the Tahoma Gateway and the Raspi with OH on my LAN connected… which Wifi connection selection you are referring to?

Tahoma Switch is a WiFi bridge by default. You connect the Tahoma Bridge to your router/DHCP server with a WiFi connection. There is an option to connect Tahoma with an ethernet adapter. Default Somfy configuration outside OpenHAB world.

I even have problema with Somfy Tahoma Switch not connected to OpenHAB. With ethernet adapter problems may would had dessapeared.

I have deactivated the somfytahoma:bridge several days ago and re-activating it has not solved the topic. Repeating it today (always with cleared Gateway IP, PIN and local token) the bridge started working again. I can access all needed data.
Whatever happened magically in last days I am happy that it works again. Unfortunately without knowing what has caused the trouble…