Tapo P110 is not supported by official TAPO Binding (OH 3.2)

What I want to achieve?

I tried to add Tapo P110.

What did I try
I installed a P110 device using the official TAPO App with my IPhone. I made sure that I can switch on/off the device via my Iphone.

1.)
I added TapoControl Binding . But there it lists only P100 and P105. I tried to use P100 instead. Didn’t work (and it would probably not support energy monitoring)

2.) I tried to somehow connect my P110 via cloud . I successes in creating a cloud bridge. But still I cannot see my P110.

2.) I searched this community and found this: GitHub - wildcs/oh3_tapocontrol: OpenHab3 Binding - TapoControl
I assume that this is not the official binding

Now my questions:
1.) Is there an official binding for OH 3.2 which supports P110?
2.) Would it be a good idea to use GitHub - wildcs/oh3_tapocontrol: OpenHab3 Binding - TapoControl. If yes how can I install this unofficial binding? (Environment OH 3.2 under DSM > 7 on a synology 928+)

I’m not familiar with Tapo hardware, but at least…

Download the jar file org.openhab.binding.tapocontrol-3.3.0-SNAPSHOT.jar and put it in the addons folder.
Before adding the new binding, please make sure you’ve uninstalled the old one.
The new binding will not be visible in other places as in Add Thing dialogue.

As there is more than one addons folder, you have to find the correct one :slight_smile: I’m not sure about Synology, is this Model docker style? Then there should be a volume for addons.

I finally succeeded.

First reply by udo hartmann was helpful. It was docker style and there was a mount for addons (which I didn’t realize in the first place).
Then I had deleted the old binding first but was not aware of the fact oh3 tries to gracefully remove old things and bindings. Thus I simply had to remove it again (2 deletes = 1 hard delete).
Then I added the cloud bridge (along with the login out of the tapo app).
And woooosh … oh automatically saw the p110

Hurray!