TapoControl Bindings - P110 cloud discovery works - p110 showing offline

Hi team,

openHAB 4.1.0.M5 Milestone Build)

Just bought a stack of P110 TAPO devices from bunnings (Australia) as they were onsale (end of stock Im guessing) andd I wanted to monitor our power usage around the house.

I installed the tplink/tapo app on my iOS and got them all to work and have been monitoring them perfectly fine for the past few weeks.
Today I decided to install the TapoControl binding to get that to work so I can graph (particularly - my sons PC use!) on HabPanel.

I installed the add-on binding, connected to the cloud, and I was able to use the discovery service - openhab found all of the devices and imported them as things.
I went into each manually and found their MAC addresses, re-named and added their IP address (which i thought weird as they are DHCP…).

none the less, under “things” all of them are showing “offline” and “Communication Error: unknown api error -1”.
This tells me they are likely communicating (as unknown API error says it tried to talk but failed) and etheral shows that there is comms between openhab and the p110 (i didn’t protocol dissect - just wanted to confirm comms)

I am wondering if there is a problem with the p110 firmware versions and communicating with the binding?
I tried an older version of OPenHab (3.2) to see if its a 4.1 problem… but that made no difference.

All P110 devices are running
firmware: 1.3.0 Build 230905 Rel.152200
Hardware rev: 1.0

Has anyone got a fix to this? I suspect this is some time of firmware-based protection to stop people fiddling with them… but I would really like to use them through openhab.

Thanks in advance.