Tasmota zbbridge Zemismart Curtain Motor with Tuya TYZS3-IPEX Zigbee

Tags: #<Tag:0x00007efecbd318e8> #<Tag:0x00007efecbd31780>

Hello People!!

I’ve just brought Zemismart Curtain motor including Tuya TYZS3-IPEX Zigbee module

I just want to try to integrate with Openhab by tasmotta zbbridge

After I pairing the device. I’ve got message like this

14:30:00 MQT: stat/tasmota_E304CB/RESULT = {"ZbPermitJoin":"Done"}
14:30:00 ZIG: Internal ZDO message 0x0036 sent from 0x0000 (broadcast)
14:30:01 ZIG: {"ZbEZSPReceived":"2400EA6E55CEA4FEFF72025C01000000"}
14:30:01 MQT: tele/tasmota_E304CB/RESULT = {"ZbState":{"Status":34,"IEEEAddr":"0x5C0272FFFEA4CE55","ShortAddr":"0x6EEA","ParentNetwork":"0x0000","Status":1,"Decision":0}}
14:30:01 ZIG: {"ZbEZSPReceived":"620055CEA4FEFF72025C"}
14:30:01 MQT: tele/tasmota_E304CB/RESULT = {"ZbState":{"Status":30,"IEEEAddr":"0x5C0272FFFEA4CE55","ShortAddr":"0x6EEA","PowerSource":true,"ReceiveWhenIdle":true,"Security":false}}
14:30:01 MQT: tele/tasmota_E304CB/RESULT = {"ZbState":{"Status":32,"ActiveEndpoints":["0x01"]}}
14:30:01 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","Manufacturer":"_TZE200_cowvfni3","ModelId":"TS0601","Endpoint":1,"LinkQuality":136}}}
14:30:03 MQT: tele/tasmota_E304CB/RESULT = {"ZbState":{"Status":33,"Endpoint":"0x01","ProfileId":"0x0104","DeviceId":"0x0051","DeviceVersion":0"InClusters":["0x0000","0x000A","0x0004","0x0005","0xEF00"],"OutClusters":["0x0019"]}}
14:30:04 ZIG: Internal ZDO message 0x0002 sent from 0x6EEA 
14:30:04 ZIG: {"ZbEZSPReceived":"9B0055CEA4FEFF72025C06"}
14:30:08 ZIG: Auto-responder: ZbSend {"Device":"0x6EEA","Cluster":"0x000A","Endpoint":1,"Response":"000A/0007":663517808}
14:30:08 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","Cluster":10,"Read":[7],"ReadNames":{"LocalTime":true},"Endpoint":1,"LinkQuality":136}}}
14:30:15 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","AppVersion":82,"0000/FFE2":21,"Endpoint":1,"LinkQuality":136}}}
14:30:15 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","0000/FFDF":"=z�'?z�'","Endpoint":1,"LinkQuality":136}}}

CT_001_L1 is the friendly name I assign to it
Problem is it come with some payload “0000/FFDF”:"=z�’? that is?? Alien language??

and when I try to manually turn motor it send message like this

14:39:52 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","EF00/0407":58,"Endpoint":1,"LinkQuality":154}}}
14:39:53 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","EF00/0407":58,"Endpoint":1,"LinkQuality":149}}}
14:39:53 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","EF00/0407":58,"Endpoint":1,"LinkQuality":149}}}
14:39:53 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","EF00/0407":58,"Endpoint":1,"LinkQuality":149}}}
14:39:53 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","EF00/0407":58,"Endpoint":1,"LinkQuality":152}}}
14:40:02 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","LocalTemperature":12.4,"Endpoint":1,"LinkQuality":154}}}
14:40:02 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","LocalTemperature":12.4,"Endpoint":1,"LinkQuality":149}}}
14:40:02 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","LocalTemperature":12.4,"Endpoint":1,"LinkQuality":149}}}
14:40:02 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","LocalTemperature":12.4,"Endpoint":1,"LinkQuality":149}}}
14:40:03 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","LocalTemperature":12.4,"Endpoint":1,"LinkQuality":154}}}

Also when I reverse it manually

14:41:05 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","EF00/0407":0,"Endpoint":1,"LinkQuality":154}}}
14:41:05 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","EF00/0407":0,"Endpoint":1,"LinkQuality":154}}}
14:41:06 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","EF00/0407":0,"Endpoint":1,"LinkQuality":157}}}
14:41:06 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","EF00/0407":0,"Endpoint":1,"LinkQuality":157}}}
14:41:06 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","EF00/0407":0,"Endpoint":1,"LinkQuality":152}}}
14:41:16 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","LocalTemperature":12.4,"Endpoint":1,"LinkQuality":131}}}
14:41:17 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","LocalTemperature":12.4,"Endpoint":1,"LinkQuality":113}}}
14:41:17 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","LocalTemperature":12.4,"Endpoint":1,"LinkQuality":136}}}
14:41:17 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","LocalTemperature":12.4,"Endpoint":1,"LinkQuality":128}}}
14:41:17 MQT: tele/tasmota_E304CB/6EEA/SENSOR = {"ZbReceived":{"0x6EEA":{"Device":"0x6EEA","Name":" CT_001_L1","LocalTemperature":12.4,"Endpoint":1,"LinkQuality":126}}}

I don’t know what does that mean. I try to command via ZbSend but nothing happen event ZbSend is respond SUCCESS

I try it with RF remote (that included in package) and their function is like reverse, forward, stop, save position. that’s all.

Anyone here ever touch this curtain motor before? Anyone can help me?

Looks like low level commands.

Thank you for replied!!

I think so. But I don’t understand how it work. I also don’t understand why it’s alway payload local temperature 12.4 ???

Can you advise how to send low level command to it? I try to learn from tasmota zigbee low level command but don’t understand it. Do you have any example to command it?

Looks like this can be supported only via Zigbee2mqtt
Zemismart_ZM79E-DT

But Zigbee2Tasmota is look like not yet support.
I will try to request for development with Tasmota community instead.