Telldus sensors - can't get back sensor that worked

I installed OpenHab and telldus core today (very much newbie in other words) and to my amazement I discovered that the sensors of a weather station my wife have were visible. So I was able to see the temperature/humidity from the three sensors. Very nice. But the names were strange so I tried to change them and it didn’t work. The reason seemed to be that the DeviceID field was empty.

After experimenting a bit I deleted one sensor and then tried to add it manually (automatic discovery didn’t work). But that didn’t work, OpenHab just reports that it was “offline - communication error”. I checked the other sensors and manually configured the sensors with the same values except that I entered a DeviceID.

So, one of the working sensors have the following settings

Name: SENSOR: 1A2D:240
Bridge Selection: TELLSTICK_DUO: UnNamed - tellstick:telldus-core:1
Protocol: oregon
Name: 1A2D:240
Model: 1A2D
DeviceID: (empty and the field has a red line to indicate an error)

The non-working sensor have the following settings

Name: Vardagsrummet
Bridge Selection: TELLSTICK_DUO: UnNamed - tellstick:telldus-core:1
Protocol: oregon
Name: 1A2D:124
Model: 1A2D
DeviceID: 124

If I run tdtool -l I get the following (edited listing).

oregon   1A2D   240 15.6° 25%      2017-02-21 22:07:45
oregon   1A2D   124 20.7° 31%      2017-02-21 22:07:23
oregon   1A2D   253 21.8° 28%      2017-02-21 22:07:18

I assume I missing something really basic here but what?

I have the same problem. It is not possible to edit the sensor “thing” in openhab, as it requires a value for the deviceID in order to be able to save it. Once its saved, the sensor goes offline.

So what I’ve done (for now) is just to don’t edit the thing and keep the values as is.

It really seems like a bug to me. Somehow the code tries to use the value for the deviceID and that results in that it goes offline. Either fix that or remove the requirement that deviceID needs to be filled in before saving the thing properties.

Maybe it’s possible to change some properties (like Location) by using the command line; haven’t tried that yet.