Telldus V2 Zwave and 433 - Getting energy info over Telldus driver

Hi all,

I have two building i have zwave equipment in, and i want both information to be in one openhab config so on building two i use Telldus V2 zwave and 433, this works perfect with temp, on/off but not with getting the energy. I just get NAN. Is this becasue the driver thinks its temp and humidity? Can i do something or is the binding not ready for this yet?

I have not tried to get this kind of data. Could you explorer a bit using the Is this a sensor or device ? Can you see the correct value in any of the replies in the api ?
If so please send me the example output and I will see if I can add it to the binding.


I will try to look at it very soon, but on travel at the moment.
In Telldus it was automaticly converted to a sensor, and openhab automaticly finds it as a sensor with the properties of temp/humidity. My guess is that maybe its a conversion fault?

It seems when you add a zwave decive, eighter if its smart plug or 5 in on sensor it will automaticly be added a device for on/off and motion detection and then a sensor for the analog values, like kwh, temp, lux and so on. See pictures.

Then openhab will automaticly find the sensors just as temp/humidity, but i think here is were it get mixed up, openhab assumes its temp/hum as i see it and will get NAN.

Did not look at the api yet as im not experiance in that, hope this will help to solve it :slight_smile:

Has this been solved in another topic?

If anyone have any info about this or workaround i would be very happy to know about it. :slight_smile:

This pullrequest adds this.

This is fantastic news!!

Will the driver then be updated shortly and it will work? Do i need to update the driver somehow?
Sorry, dont know how pullrequest works.

I think you can Use this
Uninstall the binding in UI and add this to your addons folder

Dont seems to work :frowning:
I would expect it to not show up as a Sensor but a Powersensor? This is not happening. Tried to delete all the things, reboot but still finding sensors with value NAN.

Try this

This seems to be working very good!
Thanks alot, will test it more the next days :slight_smile:

1 Like

What happened to this update?
It wasn’t merged to Master? Or will it be merged for OpenHab 2.3?

Is there any plans to create a connection to the local API on Tellstick?
As it is now, it takes a round on the internet (?)

It seems like this is not merged into 2.3.
@jarlebh do you have plans to do this? I think it would be a great contribution.