Tesla-Binding 4.1.0: Commands won't work

Good day to you all,

the last months i used teslamate as my main tool to monitor most of the data, but i would also like to send some commands to my model 3 (like unlocking doors oder opening the trunk).
I configured the binding and data like battery-charge and so on are updated. It seems that everything “read-only” works, but no commands are working.
Is this maybe related to the change for the old unofficial API vs. the new Tesla Fleet API ? Does the Binding need to be changed to this?

Commands used to work (but were often quite slow), and they still work, as long as the car is online. Did you try waking it up, say via the official app first?

While the car is a sleep a lot of the commands seem to time out with a 408 error.

2024-01-05 12:32:40.034 [DEBUG] [internal.handler.TeslaVehicleHandler] - Car has moved recently and can not sleep                                                                                     
2024-01-05 12:32:40.037 [TRACE] [internal.handler.TeslaVehicleHandler] - Vehicle is id XXX/vehicle_id XX/tokens [XXX, XXX]                        
2024-01-05 12:32:49.233 [TRACE] [internal.handler.TeslaAccountHandler] - Resetting the error counter. (1 errors in the last interval)                                                                 
2024-01-05 12:32:49.234 [DEBUG] [internal.handler.TeslaAccountHandler] - An error occurred while communicating with the vehicle during request vehicleData: 408: Request Timeout                      
2024-01-05 12:33:00.973 [INFO ] [org.openhab.core.model.script.model3] - excess is -414.51 W (+ 0W or + 2.961 W), charging is OFF, cable is IEC, current/voltage is 0 A/2 V                           
2024-01-05 12:33:40.119 [DEBUG] [internal.handler.TeslaVehicleHandler] - Querying the vehicle, response : 200, OK                                                                                     
2024-01-05 12:33:40.121 [DEBUG] [internal.handler.TeslaVehicleHandler] - Querying the vehicle: VIN XXX                                                                                  

Thank you for the reply. After your post i completely removed my things (account and vehicle) and added them again, now it works!
Now i will test it after the car goes to sleep again, to test if the Option Allow Wake-Up For Commands works correctly.

I have the same issue since I connected my new Model3 to Openhab. Unable to send commands to the car. I already tried out your solution (deleting tesla things and even uninstalling and reinstalling the binding. Everything read-only works but if I send a command I receive the following message in the openhanded.log file:
[internal.handler.TeslaAccountHandler] - An error occurred while communicating with the vehicle during request set_charging_amps: 403: Forbidden

Anybody an idea how to solve?

Hi. Did you solved your problem ? The same with a TMY 2023 : 403 Forbidden.


.

I wasn’t able to solve. It seems new Tesla Vehicles only accept commands trough the Tesla Vehicle Command SDK. In my opinion a completely new binding has to be developed. But unfortunately i’m not able to do.

1 Like