Tesla binding not using username and password after v2.2.0 upgrade "changed from UNKNOWN to OFFLINE (CONFIGURATION_ERROR)"

I have just upgraded to openhab v2.2.0, and the Tesla binding is not working correctly.

When starting, the logs are showing:


I have tried quite a number of things, but best I can tell the issue is related to this:

09:16:29.522 [TRACE] [ab.binding.tesla.handler.TeslaHandler] - Initializing the Tesla handler for 1
09:16:29.526 [DEBUG] [ab.binding.tesla.handler.TeslaHandler] - Setting up an authenticated connection to the Tesla back-end
09:16:29.527 [INFO ] [ab.binding.tesla.handler.TeslaHandler] - Found a request token created at 2018-04-18T10:05:15
09:16:29.562 [TRACE] [ab.binding.tesla.handler.TeslaHandler] - Disposing the Tesla handler for tesla:models:1 

I have tried changing the username and password in the configuration file so it will “re-read” things, but it keeps using an old request token (I think this is the issue).

The latest thing I did is remove jsondb/tesla.json file and restart, and it’s still doing this.

I’m not sure if I’m looking at the wrong thing. My thing configuration file is a copy and paste of the one shown on https://github.com/openhab/openhab2-addons/tree/master/addons/binding/org.openhab.binding.tesla - and it walk working fine with v2.1.

I’m running this in Docker, and did have to make a change to get logging working again as well (as per here Logging stopped after update to openHAB 2.2.0 Build #1010 )

Any guidance for next steps would be great!


I have now also tried changing all of the :1: to :2: (to try and create a new cache entry or what ever), and it’s worked! :slight_smile:

However not all items are working, which is super weird, for example, eventstamp is flipping between UNDEF and NULL over and over (a few times a minute). But location is updating just fine.

Thanks again!

So… it looks like this was a wet-ware issue (ie: me). I had added in the v2.2.0-snapshot to my addons folder, but totally forgot and it got pulled in again in the new v2.2.0 release docker container. So I have now removed it, and, so far, things are looking a LOT better.