The old 'Serial Error: Port /dev/ttyAMA0 does not exist' again

Tags: #<Tag:0x00007efedb08c970> #<Tag:0x00007efedb08c2b8>

I’ve spent 2 days now trying to get this to work. I have been through every thread in this forum, and tried all suggestions, but I still cannot get Openhab2 to see the /dev/ttyAMA0 serial port. Note: I started from the OpenHabian image, updated the config app, checked the various config files, to check that they have indeed been updated, check permissions etc.
I’m at the point of giving up, and sticking with ‘HomeGenie’, but I would really like to get this running, as I don’t like being beaten!

Try deleting the cache and tmp directories under Userdata That’s been working for me. Secondarily see if you have any other bindings using the serial port. I found I’m getting issues with the NX584 security binding I was using that may have been contributing to my issues as well.

Thanks rgerrans, got a bit further, serial port is recognised, but now the error is that the controller is not responding.
Having to give up for today, as some events are scheduled in Homegenie, that need to run.

I’ve solved it! The device ttyAMA0 was still listed as a console device. I cheated, and used part of the z-way server install script, that has a very comprehensive section for configuring the ttyAMA0 serial port. I can now see all of my z-wave devices … Yay!

Now I need to learn how to make use of them :slight_smile:

@evansnp can you please post the actual solution? What steps have you used to get it working? I am facing the same problem.
Thank you

@mrRobit i was facing a similar issue on a Raspberry 3 with Razberry Z-Wave Board, solved it with this thread here:

https://community.openhab.org/t/openhab2-razberry-z-wave-binding/13033/26?u=cokefridge

Seems like the serial port configuration of the Bluetooth Adapter was blocking the connection for me. Maybe it could help you as well.

Hi mrRobit; This is the code that I used.  It's messy, as I didn't totally clean out unneccessary bits, but it worked.

AMA0.xml (1.7 KB)
Note: You will need to change the extension to ‘sh’ , as I couldn’t upload it with its proper extension.

@evansnp, I ran through the code in the script, and I found out that “console=serial0,115200” was still hanging in /boot/cmdline.txt even after enabling razberry option in openhabian-config.
After removing it and rpi reboot the razberry started to work.

Thank you all for your help!