Thermostat displays the temperature wrong


I am trying to get a Powerley thermostat to display the temperature properly, I have all other control items working, and integrated with Alexa, but I have one last issue. I have it configured to display temperature in °F, however it is showing the current temperature as 20 °F, but it shows the set points correct. This is how I have the thermostat configured in the items file:

Group Thermostat “Thermostat” {alexa=“Endpoint.Thermostat”}
Number Thermostat_Temp “Temperature [%.0f °F]” (Thermostat) {alexa=“TemperatureSensor.temperature” [scale=“Fahrenheit”]}
Number CoolSetpoint “Cool Setpoint [%.0f °F]” (Thermostat) {alexa=“ThermostatController.upperSetpoint” [scale=“Fahrenheit”]}
Number HeatSetpoint “Heat Setpoint [%.0f °F]” (Thermostat) {alexa=“ThermostatController.lowerSetpoint” [scale=“Fahrenheit”]}
Number EcoHighSetpoint “High Eco Setpoint [%.0f °F]” (Thermostat) {alexa=“ThermostatController.upperSetpoint#eco”}
Number EcoLowSetpoint “Low Eco Setpoint [%.0f °F]” (Thermostat) {alexa=“ThermostatController.lowerSetpoint#eco”}
Number ThermostatMode “Mode [%s]” (Thermostat) {alexa=“ThermostatController.thermostatMode” [OFF=0,HEAT=1,COOL=2,AUTO=3]}
Number ThermostatFan “Fan Mode [%s]” (Thermostat) {alexa=“ModeController.mode” [supportedModes=“0=Auto,1=Auto Circulate,2=On”]}

Does anyone have any idea what I may be doing wrong?


The item might be expecting Units of Measurement, read Here

1 Like

I came back in to check this once I saw your reply, and it was displaying 68F, then I went and opened the items file to see if perhaps I did change something and forgot, and in that course of time, it was back to displaying 20F, and noticed this in the events log:

2020-09-30 11:50:35.173 [vent.ItemStateChangedEvent] - Tstat_temp changed from 68.36 to 20.2

I see other log entries like that too, where it seems to display the correct temp for a short while, then go back to displaying the Celsius temperature.

This is a zwave thing?
Many zwave channels use Units of Measurement, as @opus says.
You should check the channel type and see if you are using an appropriate Item type.

Yes, it is a zwave thermostat.

I added

Group Thermostat “Thermostat”, “Farenheit”

I also removed all the [scale=“Fahrenheit” tags as well, this now has it displaying the temp. correctly, however the thermostat is not discoverable by Alexa anymore. I have been only using OpenHAB for about a week at this point, so perhaps there is a better way to do this, but I have not really found any helpful examples of setting up a zwave thermostat.


Okay, don’t check your zwave channel type and see if you have linked it to an appropriate Item type.

I’m not sure what this is -

Is that something you added to your sitemap? It’s not valid syntax.

Sorry, I’ll stop adding to the noise until I have the proper time to work on this and can figure out out how to check the channel type, I am just trying to get all this working in too short of time, in between other tasks, and this is no way to properly do things.

I added that to the .items file, as I found an example of someone else doing that, and it fixed them up as well. I will work on it more once I have time to figure out how to check the channel type.


The easy way to do this is with PaperUI.
There’ll be a zwave Thing representing your thermostat.
This will have several channels.
We’re getting excited about whether the one you are interested in is of type number or of type number:temperature.
Items come in types as well, it’s fairly obvious you need channel-Item links of matching types.

I begin to suspect you may have Simple Mode active, which will have auto created Items (with tedious names) that probably conflict with anything you try to do by hand.

The channel for the sensor is showing Number:Temperature

I did initially have simple mode on, I have since turned it off, and removed devices I added with it on, and have created all the item linking by hand, and by the looks of it I had things set in my items file correct?


None of the Items you have shown us are of suitable type Number:Temperature.
Using that channel with a plain Number type Item is square pegs and round holes.

Thank, I think I fixed it, showing the correct temperature in all devices, including Alexa:

Group Thermostat “Thermostat” {alexa=“Endpoint.Thermostat”}
Number:Temperature Temperature “Temperature [%.1f °F]” (Thermostat) {alexa=“TemperatureSensor.temperature” [scale=“Fahrenheit”]}
Number:Temperature CoolSetpoint “Cool Setpoint [%.1f °F]” (Thermostat) {alexa=“ThermostatController.upperSetpoint” [scale=“Fahrenheit”]}
Number:Temperature HeatSetpoint “Heat Setpoint [%.1f °F]” (Thermostat) {alexa=“ThermostatController.lowerSetpoint” [scale=“Fahrenheit”]}
Number Mode “Mode [%s]” (Thermostat) {alexa=“ThermostatController.thermostatMode” [OFF=0,HEAT=1,COOL=2,AUTO=3]}
Number ThermostatFan “Fan Mode [%s]” (Thermostat) {alexa=“ModeController.mode” [supportedModes=“0=Auto,1=Auto Circulate,2=On”]}