Thing type: Unknown device

  • Platform information:
    • Hardware: ARMv7 Processor rev 3 (v7l), Raspberry Pi 4 Model B Rev 1.1
    • OS: Raspbian GNU/Linux 10 (buster)
    • Java Runtime Environment: openjdk 11.0.9 2020-10-20 LTS
    • openHAB version: 3.1.0

I have a Qubino Flush Shutter (ZMNHCD) that I’ve paired using an aeotec z-stick5+. I have attached two previously without much hassle, but I’m now trying to add the third without much success.

The device has been paired and is reported to be online. After healing the network it does show a unidirectional connection from the shutter to the serial controller, and an indirect bidirectional connection through another shutter.

Reinitializing the device shows this log: ==> /var/log/openhab/events.log <==2021-11-21 20:21:02.961 [INFO ] [openhab.ev - Pastebin.com . Which looks visualized like this:

I’m somewhat at a loss as to what the issue could be. I put my raspi 30cm away from the shutter in order to rule out that the distance was an issue. The config of the item looks like this:

UID: zwave:device:6e2bc4bec5:node8
label: Rolluik keuken
thingTypeUID: zwave:device
configuration:
  action_heal: false
  action_reinit: false
  node_id: 8
bridgeUID: zwave:serial_zstick:6e2bc4bec5

I’ve tried repairing, removing the device from Openhab, reinitializing it, healing it, every button I could find, but no success, yet.

Please post the file mentioned in the log:

2021-11-21 20:21:03.810 [DEBUG] [l.initialization.ZWaveNodeSerializer] - NODE 8: Serializing to file /var/lib/openhab/zwave/network_f2dccb70__node_8.xml

and the corresponding files for your two non-problematic ZMNHCD devices.

Based on your description, the last problem device was bought after the other two??. There are two entries in the DB for this type of device. One for version <4.2 and one for > 4.2. It is possible something was changed regarding either the manufacturer (unlikely) or the device IDs. The XMLs will show this. It might also appear on the UI page for the device properties; Something like 0159:0003:0052 in hex or 345, 3, 82 as regular numbers. (These should be the numbers for the working devices). If it is anything else, that could explain the issue you are having.

Bob

The issue is likely related to this -:

This is where the device reports what command classes it supports, and, well, it’s a short list. The binding relies on this list to decide what to do and how to configure the device and it’s why the initialisation stages drop through with nothing being sent -:

The only command here is the ZWave Plus Info class since all the others like manufacturer data etc are not listed as supported by the device.

It is possible to override this in the database - the problem of course is you can’t be 100% sure what the device is without getting the manufacturer information, so it’s a bit of a catch-22.

Time for a factory reset (IMPORTANT: 1st step: remove the device from openHAB: Settings → Things → → Remove device from controller)?

FACTORY RESET

Connect the device to the power supply
Within the first minute (60 seconds) the device is connected to the power supply, toggle the switch connected to the I1 terminal 5 times within 5 seconds (5 times change switch state) OR If the device is powered by 24 V SELV supply, press and hold the S (Service) button for at least 6 seconds

ⓘ By resetting the device, all custom parameters previously set on the device will return to their default values, and the owner ID will be deleted. Use this reset procedure only when the main gateway (hub) is missing or otherwise inoperable.