Tibber binding issue, OH3 Docker

Hi Guys,

Just wanted to hear if someone else is experiencing some issues with the tibber binding and live updates, under Docker environment?

I’m running OH3.1 Release Build in Docker container, on a ubuntu linux server.
Have tried all there is to try, regarding install/uninstall the binding, restart OH3, cleaning cache & tmp, recreate thing etc… But I never get established the tibber live data connection. Seems like the binding debug stops at this message:
“Starting Websocket connection”, “Initializing handler…takes more than…”
Have been in contact with the author of this great binding @kjoglums, and he’s been most helpfull. But he isn’t familiar with Docker environment. He thinks this is caused by the imported Jetty websocket library, failing to start a connection.

Any one else experiencing this or similar issues, please let us know.

Thanks
Christian

Okay, so I spun up a new docker container with OH2.5.8, and a fresh installation with only Tibber binding.
The problem persists also in this container, so probably looking at a docker issue or a problem on my linux system :confused:

Any ideas on how i would go about troubleshooting this problem??

Thanks in advance,
Christian