Timer doesn't work if time is greater than 59 seconds


I have a timer on 2 KNX controlled lights to send command OFF if there is no activity from SATEL Alarm motion detectors. To turn on lights I use simple rule and it works perfect. To turn off lights, I set timers on both items.

The issue started at the moment when I’ve removed all all items and recreated them from model as points and upgraded Openhab to version 3.1. In addition to that, I’ve reconfigured KNX router to be used as tunnel as it was not receiving updates after few minutes after restart to items. This change resolved the problem and items are now being updated when physically someone press light button.

Before all that everything was working without smallest issues for last few months.

During the testing now, I was able to replicate the problem and applied a workaround changing timer from 3 minutes to 59 seconds. In that case everything works perfect. When I change to 1 minute 1 seconds, it stops working and timer will not send any command after 1 minute.

Interesting fact is that I was able to resolve this issue few days back just by rebooting raspberry pi as I thought maybe there are some catching issues after upgrade. Unfortunately, after few days problem is back and now even restart is not helping.

Can anyone suggest what should I check as the first thing and what are the logs to enable to see if timer was started/reset/closed? I wonder if KNX bus is not sending any updates to the Item, but I don’t see it in the standard log…

May we know a little something about this mystery “timer”?

Sending screens from the UI configuration - by timer I was thinking Expiration Timer configured in Metadata


1 Like

@rossko57 Thank you, this post really helped and I’ve decided to work around described problem with virtual item controlling the light creating some roles thru GUI as I was to keep OpenHab config as easy as possible due to other aspiring home automation enthusiasts in my home not knowing programming languages.