Timesyncd only uses FallbackNTP servers

  • Platform information:
    • Hardware: RPi 4 4 GB
    • OS: Raspbian GNU/Linux 11 (Kernel 5.15.32…)
    • Java Runtime Environment: ?
    • openHAB version: 3.2.0
  • Issue of the topic: timesyncd exits with a “too many retries” (or something similar) error. After changing timesyncd.conf to use different NTP servers, only the servers in FallbackNTP are used.

timesyncd takes configuration from different locations.
Check if other locations override your settings.
The manual page timesyncd.conf(5) — systemd-timesyncd — Debian testing — Debian Manpages describes the loations where settings can be put.

I had 0.debian… as the first “Fallback…”. I moved 0.debian… and 1.debian… to the NTP= line and the result was that the logs started having 2.debian… as the address of the used IP (first in the FallbacckNTP= line)
I changed the settings at /etc/systemd/. I suppose that file has the highest priority.

I assume that there is an other file that has higher prio and NTP is set to an empty value.
Then it looks like the fallback value is taken.

But I have 2 servers at the NTP= line (0.debian… and 1.debian…)
Why are these servers not taken into consideration and why are the other servers in the Fallback line (2.debin… 3.debian…) considered?
Before I moved 0.debian… to the NTP line, it was the first in the Fallback line and it was the “used” server.
Why are the servers of the NTP= line ignored?

Have you read the manual page I was refering to ?

I did a test here on my system.

cat /run/systemd/timesyncd.conf.d/dhcp-ntp.conf
# Created by dhcpcd hook

With the above content it behaves in the same way as you describe your system.
I manipulated the above file and changed the NTP= line.
Then I started timesyncd again and the content of that files NTP variable is being used and not the fallback value.
But it will not work to manipulate that files content. As it is by DHCP.

Thanks a lot.

1 Like