TimeZone DST - Log shows 1 hour behind

Tags: #<Tag:0x00007fc8fcc32950> #<Tag:0x00007fc8fcc327c0>

How can I set that the DST will be used?

I have set inside the Paper UI the timezone to GMT+1.
timezone

On the rasperry PI with openhabian I see the time without DST.
timedatectl

So now it is 15:13 and I see 14:13 inside the logs and on the CLI.
So I think also the rules are running with time 14:13 instead of 15:13.

Have you tried using sudo openhabian-config tool and select option 30 then number 33 to set system time?

Thanks this solved the problem. Now I see from timedatectl the time 18:44 and now it is 18:44.
The log file still shows one hour before 17:44!

Let’s see if the rules are working now as exptected.
Thanks again.

1 Like

You may need to restart OH and if that does not work then stop OH and clean the cache. :wink:

1 Like

After reboot the log is also correct.
So I think all is fine now.

Thanks.