To Forum Admins: Documentation Link Broken

To forum admins: the Documentation link (see below) is broken!


No, just tried, it is working for me…

Yes, just tried, it is broken…

It is not …

please try a ping to

Oh yes it is!

No, there seems to be a network conjestion

Some pings respond, some not. But the link is not broken…

Ok, if you want to be pedantic, I agree that the link is pingable. But if I click the link from the forum page it delivers a garbage page to my my browser (with a black rounded rectangle, as shown on my screenshot). I can send you the garbage html or a screen capture video if you want (please tell me where to send it).

No, I don’t want to be pedantic, but I can access it through the forum link, which is the same like opening on a seperate window.

Ok. Stopping this.

The link is working for me. The system status page shows everything is up and running. If it’s not working for you I recommend clearing your browser cache and trying again or look into what might be going wrong with your network. There really isn’t anything we can do about it from our side since it appears to work just fine.


It is working for me, too.


1 Like

Well below is what happened to me…

openHAB Forum Documentation Link Garbage

… but you know what, life is too short to continue this discussion further…

Except if there is something wrong for you there is possible something wrong for other users too and it would be nice to know what is wrong and how to fix it.

It’s not that we don’t believe you have a problem. It’s that we can’t do anything about it from our end.

It’s not happening for us and there is a whole world between your browser and the OH docs servers that we don’t have control over. Maybe you have a browser plugin that’s causing problems. Maybe antivirus is mucking things up. A proxy, VPN, ISP issues, the Amazon cloud service outage, etc. The only one who is going to be able to diagnose and fix this problem is someone who is experiencing the problem in the first place.


@AndrewFG, I think the confusion stems from how you initially described the issue, so your screencap helps a lot.

I actually ran into this yesterday, but it wasn’t due to clicking the Documentation link. Instead, I was in the current 3.1 documentation and clicked the button to view the 3.2 documentation.


I saw the black bars that you showed, but all of the page content was just further down the page, and it wasn’t styled properly. That usually means there’s a caching issue with the CSS style sheet. I can’t reproduce it now, likely because my browser has refreshed. However, that doesn’t explain why it’s still happening for you if you’ve also refreshed your cache.

For web maintainers (part of my day job), a “broken link” usually means that clicking on it gives you a 404 error, because the page doesn’t exist or the server is down. But in this case, the link was fine. That’s why you see the URL in your screencap change to “”. The real issue you’re reporting is that the page you’re getting to isn’t displaying properly.

If you force a hard refresh or use an incognito window, your browser should ignore the cache and download the CSS style sheet and webpage directly from the server. Theoretically that should fix it, but as Rich noted it might also be due to something else between you and the openHAB server that’s serving outdated content.


Good lord gentlemen…


This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.