Toggle FritzBox guest LAN-Port?


is it possible to toggle the guest LAN? In the fritz-binding i only found the option to toggle the guest WLAN.

I am using the same docking station for my private and my company’s laptop. As I really don’t want to have the company laptop in my private network (lots of services running there), I unplug the network cable and use the guest WLAN. Which is not really ideal for video calling (plus the hassle to plug/unplug the network cable every time).

If it was possible to toggle the guest LAN port, it could be triggered automatically when the company’s laptop MAC-Address appeared in the network. Is there any way to accomplish this?


Like, have your router DHCP assign this mac an IP on a different subnet?

I don’t think that can be accomplished, at least not with the standard firmware, for two reasons:

  1. There are no dependencies to influence the option of assigning port 4 to the guest “VLAN” (behind the scenes it is basically VLAN technology that AVM uses to seperate the networks). So you can only switch it on or off. No detection which device is attached.
  2. As far as I know, you cannot access the configuration of your FritzBox from the guest VLAN, which would make it a one-way-option: your docking station would be connected to port 4 (the only LAN port that can be assigned to the guest VLAN). Once that switch is done (port 4 is switched to the guest VLAN), every device you connect there will be part of the guest network. Which means you have no longer access to the Fritzbox options via that LAN port and therefore you cannot switch the port back to the “normal” VLAN through the binding when your private device is attached.

I think you would need a managed switch for this ( between the Fritzbox and your docking station ).

Is it possible to set DHCP-settings and subnet per device with a FritzBox?

I think switch-like behavior would be sufficient. Both Laptops are on LAN-Port 4. If the company Laptops is detected, a rule to toggle the switch is triggered. There would be a small amount of time, while the device is in the private network, but I think this would be acceptable (maybe block the devices internet access).

Switching back the port to the internal network via a 3rd device (I use my smartphone to control openhab) would still be way more comfortable than switching cables.

Additional hardware might be the “last” solution, if there is no other way.

I didn’t know if it is possible for the binding (or any other external software) to change the configuration of a fritzbox port.

But practical workaround could be to just use an extra cable parallel to your current one.
So just have both cables (e.g. one in port 3 for private LAN and the other in port 4 for guest LAN) near your docking station and plug in the one you need.
Of cause this requires a second port on the fritzbox for your docking station.
If you only have one cable from your fritzbox to your office you could split the cable in two (each 100MBit/s) cables.
for example:

What you are asking as a solution could be achieved by using IEEE 802.1x (MAC Authentication Bypass) in combination with dynamic VLAN assignment.
But that is far to complex for your situation and would require additional hardware and software.

If you can swith the setting with a third device, that will be possible, but will need manual interaction.

Otherwise I only see the solution with two cables and plugging the necessary one into the docking station or additional hardware between the FritzBox and the docking station that manages the connection (might be difficult as the docking station most likely has its own MAC address and does not show the MAC address of the device that is plugged in).

Valid point i didn’t thought about - my old docking was just an electrical pass trough of the ports, the new one USB-C. So I would be stuck with cable switching or wifi…

Newer business notebooks (like Dell) have a feature called “Mac Pass Through” so the Dock gets the MAC address of the notebook.
But I never tested this.

Docking and Laptops are different brands…
Thanks for the help!